Tarot 680 Hex, Pixhawk, EZ SONAR

I've never had a problem with altitude hold or GPS hold functioning in the past. I added a Botix sonic ragefinder that I have used on an APM frame without issue. Now my hex cannot stay at constant altitude and translates up or down when I am at mid-throttle. I still have altitude control with large throttle moves, but it won't stop when I mid-stick, it sort of just stops trying to change altitude as if it it changes to throttle-hover without reading the baro or sonar. Throttle is calibrated correctly.

If I had enable the SONAR in firmware but the module was disconnected, would my drone be expected to behave this way? I know that the read voltage on the board floats if a sensor isn't connected. Hopefully I can troubleshoot this out of the system tonight or tomorrow morning.

Thanks for your help!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Please post the .log file so we can have a look

    • are you saying that my sonar is always reading between 20 and 30 centimeters? that could be caused by my landing gear. I have tried to mount the sonar out of the way but perhaps I need to angle it outward.
    • Logs added.

    • Your log show STABILIZE and LAND modes.

      Stabilize do not use Sonar because it does not control altitude. it's direct throttle control, that's why the copter behaves as you describe.

      You should try Alt_hold, loiter or poshold flight modes

      BTW, sonar readings are between 23 and 34 cm, not relevant then.

      Try to connect the sonar properly and test it (with mission planner) before flying.

    • Turns out the cause was my sonar. Once I disabled it in firmware the hex could hold steady height.

      Sonar was probably detecting the landing gear foot, confusing the altitude readings between baro and sonar.

This reply was deleted.