Quadcopter nose dive on first flight

Hello everyone,

A couple of minutes ago I tried to fly my quadcopter for the first time. Unfortunately it ended in a nose dive before even taking off. Something I noticed was that when I raised my throttle by a tiny bit (from fully down position), the motors started to spin immediately and speeding up by itself (like it was stuck in a exponential thing), followed by the nose dive. I am using a Pixhawk flight controller. What did I do wrong? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Well, I got my quadcopter in the air today for the first time. Not for long, but long enough for a really short test. Can someone please look at my Log file and give me feedback. I would really appreciate it. 

    Also, what is the best way to change the pitch direction, on my Taranis or in Mission Planner using RC3_rev?

    2017-08-11 13-11-13.bin

  • Mert, replying to your last post..

    Sounds like you loaded 3.5.1 APM which includes new features and New prearm safety check Before it will let you ARM the copter. There are two ways to resolve this, one more correct than the other however, if you are a bit new to this, may want to take the later approach. 

    I reference documentation here..  http://ardupilot.org/copter/docs/prearm_safety_check.html

    The Firmware thinks you have the default original PWM values which are Rarely correct, thus the warning...

    Read the link above to disable the prearm check if you wish.. look for RC...

    Lastly,  as I didn't see anyone give detail on this... if this is a quadcopter, you are using 2 Clockwise props And 2 Counterclockwise props... right?

    As noted here under PROPS.  http://ardupilot.org/copter/docs/connect-escs-and-motors.html

  • you need to make a video of your configuration steps. very difficult to follow you. What does one green bar going to the right means? Not following you.

  • I get the PreArm RC Roll not configured alarm and also I tried to calibrate the compass, but just one green bar is going to the right. The second one does not appear..

  • https://youtu.be/nwRafwC5_kY

  • No- I have the same values.


  • Maybe this parameter is the issue?


  • This is very easy to troubleshoot. Next time, simply test the motors inside your house without the props like a real setup. Put some tape on the motors, and piece sticking out. This way you can observe as the motors spin and as you increase the speed. If everything looks good, put the props back on.

    I am not sure what happened last time. Put a RunCam or something on your hat and video tape the whole test in the field. It always helps to see things in action to understand whats really going on. You still have not provided crucial details about your quad such as Quad type, ESC type, Motor Types, radio receiver type :)

    I just tested my custom Hexa-quad, flew like a charm. I will be posting the video on iSkyMaster youtube channel tonight.

  • There is just one thing that keeps me thinking: the fact that the motors started speeding up when I raised the throttle stick a tiny bit. I have no clue what the problem is. I made a new model on my Taranis to start from scratch again. Hopefully this time I won't have the same problem..

  • I did not have the chance to fly because of weather conditions. Tomorrow will probably be a good day to fly, so fingers crossed.

    iSkyMaster said:

    So did it fly?

This reply was deleted.