TBS Discovery & Pixhawk load of problems :(

Good morning DIY DRONES,

You guys are my only hope as I have tried everything I can to fix this problems but it seems like an never ending journey.

So, let's me start by saying that I have followed and researched about every possible way to build a TBS Discovery with Pixhawk but my knowledge is still very limited, as I keep on reading, I feel like I have made so many stupid mistake.

So my TBS build list:

TBS Discovery w/ core.

900kv TBS motors and bulletproof escs

9x5 propellers

Pixhawk w/ GPS

4500mah 4s battery.

I have been facing so many problems since thay day I switch from 750kv to 900kv, as everybody said the samething, 900kv is way much better, better bearing, i choose 900kv for long flight etc...

After I install the 900kv on my tbs, everything started to fall apart, Mag_field is really high, over 680 :( Vibration is absolutely ridiculous (eventhough my X+Y axis is still under range but my Z is way beyond measure). My quad could not hold position or altitude, when I fly in stabilize mode it seems to be okie but when i switched from stabilize to either Loiter or Altitude hold, the quad started shooting up and down just like when you change throttle from lowest position to highest in a matter of second. I have to switch to stabilize mode immediately other it will keeps going up.

Could you guys please help me to make this right, i'm truly desperate, i have tried everything but non of them seems to work. 

Please find my attachment for the log file, i have tried to fly it as long as i can to review the problems. Please DIYDrones, you are my only hope. 2014-09-12%2023-29-04.log

P/s: I have calibrated all escs,  compass, etc.. I followed the introduction closely but non seems to work




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi dont know if this will help but I had some weird issues like yours once and found the pins were coming loose from the plugs going into the mag and gps. in the photo it looks like the rearward mag pin is out a bit??


  • Okay - really reaching on this one: You've got the Mag wire and the GPS wire bound together.  You may be getting interference from the power lead to the GPS into the feed line for the compass.  Simple to separate them and see.

    Good Luck.

  • Now understand that I'm no developer, but it doesn't make any sense to me why rolling back from one stable firmware to a previous one would fix anything like this, but you never know. 

    That being said, there are lots and lots of folks running TBS Discos and Disco Pros on the Pixhawk with current firmware with none of these issues, so I'd would look for something else. 

    At this point, I'd recommend upgrading to 3.2 rc9. It's nearly done and is working pretty well. I installed it last week on my Disco Pro and haven't had any serious issues thus far. 

    I don't remember if you did this or not, but have you RESET your Pixhawk? This puts all of the settings back to the factory defaults. Updating firmware is one thing, but it doesn't RESET when you change the firmware. This is the very first thing I would do. Then I would update to the newest firmware (I'd personally try the 3.2 rc9 beta), then go through the entire calibration and setup wizard again (you have to do most of this anyway for 3.2, but you would need to do it if you reset your Pixhawk as well). Also calibrate your ESCs one more time, just to be sure (this probably isn't what's affecting it, but it doesn't hurt just to be safe).

    Lastly, I would have to assume that you've done this, but it needs to be said to make sure you don't have any funky settings on your RC. Make sure they're all plain vanilla or even start with a new model on the RC to clear out anything you might have missed. 

    • 3.1.4: I don't know why going back from 3.1.5 eliminated the throttle problem.  I do know that it fixed 3 different Disco's with the exact same problem.  It may have been erasing the eeprom that went with a firmware change.  Every time I tried to reload 3.1.5, I'd get the "No Need. Already On-board" message.

      3.2 rc 9 : 12 minutes test today confirms that it flies fine.  Now I can start the fine tuning process again.  I'll have a chance to wear it out tomorrow.  Poring over logs tonight.

      Kristian: Thanks for your input.  Don't go away!

    • BYW, do you have your frame type as 'X' or 'V' ?


    • I don't think there is any issues between X or V type as it is somehow the same, it is only matter if you choose H style.

      It is pouring rain right now so I can't get my quad out for a test, but I will try it as soon as I can.

      Thanks you for all the help and support.

    • 3.2 beta provided these result. Mute point now. New motors and ESC's orderd3702828147?profile=original

    • Guys please help. I have tried every single possible way and can not find the root of the problem. I really want to make this work. Please advise on what should I do.

    • Hi Long,
      I had some crazy mag readings until I discovered my mag was plugged into the wrong port on the pixhawk. Once I got it plugged in it was actually reading it and I was able to do the calibration dance with good numbers.
      I see in your pic that you are using the i2c expander board. You might try bypassing that and plugging the mag cable direct into the i2c port.
    • sure then, i'm definitely going to try it later on today. Thanks for your comment.

This reply was deleted.