trouble with pitch: dji f330 w apm2 and ac3.01

Hi everyone..  I could use some help.  I created a video of the issue I am having.  I am trying to get an original APM2 board circa april 2012 to work on a DJI F330 with 30a Opto ESCs and 2212 motors.  Everything seems to work fine now except pitch.  I have all flight modes set to stabilize and am simply trying to lock in a stable hover inside my garage.  The trouble is the quad will drift, NOT oscillate and when I give corrective stick inputs, roll works as expected however pitch does not.  I find that pitch input will often show a delayed response from the input to the copters change in pitch and at that time the pitch changes very fast so that the quad will just take off.  I have tried tuning the PIDs however now the quad is exhibiting the behavior that forward stick will sometimes move the quad backwards and change in pitch does seem to cause some osicilation.  From my readings, the oscillation sounds like too high a Stab Pitch P entry.   I have tried moving from the default of 4.5 to as low as 2.5 and still I am having issues.  Any help would be greatly appreciated.  Also, the APM is mounted on Zeal gel so vibration should not be an issue.



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok so not sure what fixed it but I was able to reflash the apm2.0 with ac3.0.1 and all seems to be fine now.  I did redo the live calibration and the accelerometers too.  I have not had to tune the pids though I will start with the f330 guide next time I have her out.  She is flying pretty good in stability already and I will be testing out loiter next.


  • I think you may be adjusting the wrong parameters. 4.5 seems too high for pitch/roll stab P values. I think you are adjusting the 'stick response' values, which I always leave at 4.5, or 45deg. My stab values are in 0.015 to 0.15 depending on airframe/motor setup.
This reply was deleted.