'uBlox 6M GPS Module V2' and APM 2.5.2.....WTF!!!

Does anyone know wtf is up with this 'uBlox 6M GPS Module V2' that i just got from RTFquads? I just set this board up and i am trying to get this all going but for some reason it isn't being seen by the APM. I tried to upload the GPS passthru to the APM following Randy's youtube video but i couldn't get that to see it either?

Anyone know what these sequence of light are?

Really want to get this quad in the air asap but this seems to be what is stopping me. When i connect all i get is 'NO GPS'....

Any help is totally appreciated. THANKS!!

this is the gps:

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • Yeah, that has to suck.  Any chance your 3.3v regulator may be bad?

      The test is here.

    • Hey Crady,

      I would love to test that but i am not getting the symptoms that Randy is displaying... Everything works just fine and dandy except the GPS. What i am thinking is that the GPS aint comfigured correctly, but i tried doing the GPS passthru (loaded the firmware) and then loaded up uBlox center but could not get it to see the gps. Maybe the GPS is bad... but why is it blinking...

      just bums me as this quad is so ready to fly otherwise.

    • Admin


      The uBlox needs to communicate with the APM at 38,400 baud. The default baud rate is 9,600. Also, the APM is expecting to see the uBlox GPS configured with the custom 3DR firmware found here: Config File

      Are you sure that you have the tx and rx lines connected correctly from the GPS to the AMP?


      TCIII ArduRover2 Developer

    • Developer

      The incorrect baud rate would explain the problems including the inability to use the GPS pass-through.  If you're comfortable compiling the gps pass through sketch yourself with arduino you could replace the 38400 with 115200 in these two lines of the sketch.

    • Mark,

      Do you have an FTDI cable? If you do use it with UCenter which you can find on-line from U-Blox. UCenter has a lot of tools and you will quickly know if your GPS is working. However there can be some issues with different FTDI Cables. You can download the 3DR firmware that Mark mentioned above which will set up the correct baud.

      Also you can look at your log files it will show if you are getting any response from the GPS.

      If you don't have a FTDI cable I would invest in one. They are cheap and very handy to have.

    • Hey Randy,

      I tried to compile it a few times doing different things to try to get it compiling correctly, eg putting in libraries into the sketchfolder....

      Unfortunately i got nowhere. Is there anyone who can successfully compile this sketch and upload the hex here? I am pretty sure if you know what you are doing this would prolly take 30 seconds, yeah?

      Thanks in advance...as i am feeling really frustrated like just giving up here.

    • Randy-

      I am not too familiar with the Arduino IDE but I did a git clone and went went to that file in the Arduino IDE and tried to compile that file:

      and at the bottom i got:

      GPS_UBLOX_passthrough.pde:10:23: fatal error: AP_Common.h: No such file or directory compilation terminated.

      Any help is totally appreciated!

      Thanks all!

    • thanks randy, et al.

      going to try this.

    • Sorry, man.  It does sound like the GPS module is bad.  But while you're getting it sorted you should still be able to fly -- you'd just be missing out on any GPS-centric features.

This reply was deleted.