uBlox new 6m and APM 2.5.2

I am trying to finish setting up a quad in which i have ordered many different parts. At present, i am having a bit of trouble setting up the GPS, attempting to flash the ublox using the ublox center. Unfortunately i have not been able to so this successfully.

I have everything else to complete this setup (FPV and such). What is strange is i ordered a ublox 6m neo gps from witespy quads (http://witespyquad.gostorego.com/flight-controllers/ublox-6m-gps-module-no-mounting-backplane.html) which didnt seem to work with the APM 2.5.2. It looks like it is working (leds blinking red and green) but when tested in Mission Planner terminal it spits out junk...so I assumed it must have been because it's baud rate was greater than 38400. The leds light up and about a minute after being on the green light starts to flash and the Mission Planner displays No GPS.

 So because i really wanted to get this thing going i just ordered another from hobbyking and today i received it [this one: http://hobbyking.com/hobbyking/store/__31135__NEO_6M_GPS_Module.html ...

Anyway, i am totally stumped and now just pissed as it seems to be the APM or something else. I went into the terminal to test the gps and all i was getting garbled text... So i have no idea what will get this working.

That is two ublox gps doing the same thing producing the same results. Bllahhhh!

I have also tried unsuccessfully to get the ublox center to update with the 3dr gps file.

So anyway. If anyone knows anything I would be super happy if they would share.

Thanks for reading.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi, I had the NEO6s work well with any APM. The NEOs are a downgrade from the LEA6s that 3DR etc. sell but AFAIK all the removed features are not needed anyway.

    You mention flashing a NEO6, and programmable flash memory is one of the absent features on NEO. However all decent modules have a backup battery and/or an I2C EEPROM and you can store configuration to those.

    Im sorry I cannot get the config details right now.

    I had a NEO6 fly at 60000ft, it still had 3D lock and all. Definitely not unsuitable for flying.



  • Mark read this. Does that sound familiar?

    can you measure the amplitudes of the data levels? (with an oscilloscope)

    I had some trouble with data levels on an ublox 



  • Using FTDI and UCenter press the autobauding button and try to reload defaults. If that works you can then upload the 3DR script.

  • Developer

    Try connecting at 9600 baud using uCenter, I believe, of the top of my head, that is the default baud rate. you'll need to configure it to 38400 for the APM

    • Admin


      I believe that you have to load the 3DR configuration file at 9600 baud and then the baud rate will be changed to 38400 baud by the configuration firmware. At least that is the way it worked for me when I updated the configuration firmware on an older 3DR v1.1 uBlox LEA-6 module.


      TCIII ArduRover2 Developer

    • Hi Tom,

      The uBlox Center seems to connect at 9600 but when i try to upload the 3dr file to it is doesnt work.

      It does one of these jobs:

      Sending: MON-VER -  B5 62 0A 04 00 00 0E 34 ...
      ... timeout occurred without receiving an answer. Retrying...!
      Sending: MON-VER -  B5 62 0A 04 00 00 0E 34 ...
      ... failed due to timeout!

      This probably takes 10 sec to do but I am getting nowhere with this configuration upload.

    • Hi,

      Not really sure how to configure this gps to 38400.... but i did follow this lightly: http://www.drotek.fr/ftp/pdf/ublox_EN.pdf

      In anycase, it still wouldnt let me upload the 3dr config. man, i am about to pull my hair out this is so freggin frustrating!

      I managed to hack a ftdi cable to the gps and now the uBlox center connection is blinking... not sure if anything is working though. Every time i try to upload it fails.

      any help is totally appreciated.




  • I am using the same gps and had a similar problem- are your esc's also plugged in? If so try to acquire a gps with a usb connection only.. If you aqcuire its a magnetic field issue. I found with my gps on the top of my frame I couldn't aqcuire any satellites but seemed to get full response by elevating the gps by 3 inches. Hope it helps

    • hey jake,

      unfortunately it aint a satellite/ performance issue. It is a connection/ hardware issue as it is reporting 'No GPS' in MP wen it is plugged into the new style gps slot on the apm.

    • thats tricky. If you havent tried already attempted i would try adjusting the baud rate

This reply was deleted.