Unable to Calibrate/Arm ESCs

Hey everyone I need some help here,


I followed the instructions in the wiki which are as follows,


In-field ESC calibration

This method works once you have all the ESCs connected to the power distribution board and have connected all your RC cables as instructed earlier in the manual.

Safety first - Remove props!

  1. Disconnect USB
  2. Put the throttle high and connect the Lipo to power the APM
  3. When the APM boots the lights will cycle
  4. disconnect the Lipo and reconnect it. High PWM will be sent to the ESCs triggering calibration
  5. Drop your throttle stick to the lowest position. You should hear confirmation/arming beeps. Move the throttle to confirm all ESCs are armed and working in sync.
  6. Unplug the battery. Your ESCs are now calibrated. No further action is required.


But I am unable to get the ESCs armed. I am not getting the confirmation beeps as mentioned in the 5th point. I tried manual calibration and that worked but the in-field calibration doesn't seem to work at all. 


Any help is appreciated. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I had the same issue

    Try putting 


    in your apm_config file and see if that solves your problems as the esc's may not like the 400hz refresh rate


  • Try manual calibration with lower throttle set a bit higher than normal. Arm with lower throttle point set just a bit higher than zero. This helped me after I've tried anything else.


  • what is your transmitter and receiver ?? 

  • Developer

    This method only works on the latest code. 

    Also, are you able to manually calibrate? Meaning you can put the ESC into CH3 of your radio and calibrate? 

    Some folks low PWM value is too high for these ESCs and you need to trim down your throttle to get it to output a lower PWM value.

This reply was deleted.