hello guys

i want to upgrade my quad jdrones apm 1.4  atmega 2560 to the new code arducopter 2.9.1

but i've some problems :

software : mission planner 1.2.33 mav1.0

and arduino 1.03.modified for atmega 2560

windows xp

and code arducopter 2.9.1(the two folders Arducopter and libraries)


first problem with arduino :

I then open the sketchbook Arducopter. That gives me plenty of tabs in the Arduino IDE.

I click Files/upload and I get plenty of compile errors. I provide the log here under. Does anyone knows what's wrong in the process ? Did I miss something and wrongly configured something ? Or did not configure something ?:

C:\Documents and Settings\yoda\Mes documents\ARDUINO\libraries\AP_Relay\AP_Relay.cpp:19: error: 'AP_Relay' has not been declared
C:\Documents and Settings\yoda\Mes documents\ARDUINO\libraries\AP_Relay\AP_Relay.cpp:25: error: 'AP_Relay' has not been declared
C:\Documents and Settings\yoda\Mes documents\ARDUINO\libraries\AP_Relay\AP_Relay.cpp:31: error: 'AP_Relay' has not been declared
C:\Documents and Settings\yoda\Mes documents\ARDUINO\libraries\AP_Relay\AP_Relay.cpp:37: error: 'AP_Relay' has not been declared
C:\Documents and Settings\yoda\Mes documents\ARDUINO\libraries\AP_Relay\AP_Relay.cpp:46: error: 'AP_Relay' has not been declared

what can i do ?

so i' ve tried with MISSION PLANNER but... :

the second problem with mission planner

the jdrones apm 1.4 to connect wiht the program to 38400 bauds ... normaly  it's 115200 baud

how i can change that?

and when i try to upload the lastest  firmware by the program it's say "firmware is to big for a1280 please upgrade your hardware! picture joined 3690992391?profile=original

i don't understand i've have apm1.4 with 2560 so....

can you help me?


i've have read  yet many answers about this differents problems but wihtout solutions

so Jani (jdrones) can you help me about that?)

is it necessary to erase the bootloader apm 1.4 to upgrade to arducopter 2.9.1?

thank you in advance for your help

grr  i' just want to fly  lol

sorry about my poor english.. so frenchy!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have APM 1.4 , compiled 2.81 and 2.91, no problem.

    Try copy all the libraries  under   ArduCopter-2.9.1\libraries  to   ArduPilot-Arduino-1.0.3-windows\libraries and verify compile it .

  • Developer

    Yann, can you please contact our customer service via jDrones Contact Us form. So we can look what to do with your board. That 38400 baud sounds really weird as all our boards are using same software and electronics.

  • Hi Yann,

    Let me try to debug this problem with you.

    Does everything work when you upload an earlier version of APM code, like 2.x.1. If it works for this version, there might be possible problem with the latest update with Arducopter 2.9.1.

    From your problem description I find:

    software : mission planner 1.2.33 mav1.0 : Looks Good

    and arduino 1.03.modified for atmega 2560: Looks Good

    windows xp: Looks Good, should not be a problem here

    and code arducopter 2.9.1(the two folders Arducopter and libraries): Might be a problem here.


    Try these baby steps (possibly you already know, but try once more by following these steps strictly):

    1. I go to Arduino Sketchbook software.

    2. Set my path under File-> preferences, sketchbook location to: C:\Users\localUser\Documents\Arduino (I will call this path as my ROOTFOLDER)

    3. Make sure you selected Tools-> Board-> ATMega2560

    4. Tools-> Programmer: AVRISP mkII


    5. Unzip the Arducopter code 2.9.1, copy the library folder to ROOTFOLDER.

    6. From the extracted folder Arducopter code 2.9.1 copy the Arducopter folder into ROOTFOLDER.

    7. In the arduino sketchbook, click File->Open, choose the Arducopter.pde file. Please make sure Arducopter parent folder name under ROOTFOLDER contains a file with the same name and extension .pde OR .ino (Arduino does not like otherwise)

    8. Click on Sketch->Compile/Verify. (No need to upload now). Check if this builds, if you follow have followed well until now, it must work.

    Second problem: Change BAUD RATE: 

    Solution: Change it in the Arducopter code. Change it easily in config.h OR APM_config.h. Change Baud rate #define from 115200 to 38400. Please SAVE the file after doing this. Keep following the steps below (strictly).

    9. Reopen Arduino IDE (yes, re-open it), redo the above mentioned steps 7,8. If compile succeeds, all good. Sketch->Upload it, NOW. Now, the binary code sits happily on the ATMega2560.

    10. All good so far, great! Open Mission Planner (it reads from/ writes to ATMega2560) . Change the BAUD rate, Click on Connect Icon (It must connect).

    11. If you arrive at this step, you have re-solved it all. NOTE: You don't now have to upload the code through Mission Planner (like how you do in the screenshot, it is already uploaded for Baud_Rate 38400).

    A slender possibility can be with Arduino-1.03 backend, but that has something to do with AVR library compatibility with Arducopter library usage. But I think, they have taken care of this compatibility already;)

    If not, ask me, I will try to help further;)




This reply was deleted.