USB Communication Issue


I just bought an ArduCopter Kit a few weeks ago and finally assembled it. Now I have some issues communicating with the board via the APM Planner. 

Here is a bit of history of my problem:

1. I was able to connect, download and configure the software using APM Planner

2. I setup the RC, ESCs and everything else successfully

3. I've assembled the kit completely and was able to arm and control my servos fine

4. After swapping the ESC connections to configure the correct direction for all motors. Reconnected to battery and everything worked well.

5. Installed the propellers and connected the batteries. Some ESCs start beeping and the servos were twitching

6. After that I could not re-arm my ESCs but the RX was working since I've seen the send blinking

7. Disconnected the the ESCs and battery and tried to re-program the board. Then I realized i cannot connect anymore.

Here is exactly the symptom i got now:


  • If I start the terminal, i get the following line "Opened com port" which means that my USB connection is established but the board does not reply. I see the Tx Blinking each time i type something in the terminal so it seems that the software is not running or nothing comes back.Usually I would expect to get back the APM version and the prompt.
  • Also trying to update the  firmware, I can see the APM Planner trying to query for the APM version and after that it fails with the error - "Cant detect your APM version. Please check your cabling". 

Other facts:

  1. To prove the the Rx works I short the Rx and Tx  pins I can echo back everything I am typing so that makes me think that everything is fine with the USB Cable and the FTDI cip.
  2. I have checked for cold soldering again i think everything is fine.
  3. For a week I put this thing on a side and started working again on it today. Interestingly enough I could connect fine once, was even able to re-load the latest ArduCopter software and played with the terminal for a while. After that I tried to get some Flight Data, flipped the CLI switch to FLY mode and connected. It connected well, the MavLink dialog box started to receive data but that's where is died again. No data was received and I am back to square 1.. Not data comes back form the APM...


Can somebody help me figure out what's wrong? There is nothing more upsetting than having everything work for 10 minutes and then stop... 


I want to mention that I've tried connecting with different USB cables, have no driver or connectivity problem as I was able to communicate well with this board initially. 


Does this point to a bootloader issue? 

Is there anything else i should test, try, measure to provide more insight? Any thoughts?


Thank you very much for help,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I ve contacted the support my order is older than 30 days they can't help ..... 30 days like the time you have to go to the bank to retract.
    Brand new hardware never used, destiny -> to the bin ... what a waste ! 


    "Belle quenelle" !!!!!




  • Hello,


    I've the same weird problem,

    and in addition, I can't do a physical Reset on my board IMU (nothing happen even if I do a reset on the red Board APM with a tiny wooden stick).


    So, I've tried 2 things maybe that can help you for the diagnostic:


    1. All off,
      • I switch ON lipo with electronic converter (5V) to the APM by the ch1 of my transmitter.
        • 2 LED on APM are solid(red and orange) 1 blue blink, 1 blue LED on IMU is solid.
      • Then I connect the USB cable,
        • some TX and RX blinking few sec and off; but still (2 LED on APM are solid(red and orange) 1 blue blink, 1 blue LED on IMU is also solid.)
      • I Can't connect on the APM planner. with the right com port and 115200 baud.
    2. An other test without extra power source.
      • All off,
      • USB connected, 3 LED on APM are solid, 1 blue LED on IMU is also solid.

    If I open with arduino the serial monitor, nothing happen even if I'm right configured (CR and Bd rate)

    but when i Hit the button Send, the TX Orange Led on the IMU sensor board flash.

    I've tried to enter "reset" but nothing happen.


    Thanks for helping :)



  • I have the exact same issue and I've noticed that playing with the USB connector help me to get it connected but only a few second unless I hold it on a very precise position .....

    For that price of hardware I guess we could expect a bit more than a 35cts USB connector not able to hold the cable correctly ....

    I ve been through forums and have seen that quiet a lot of people have an issue with that connector.
    I guess I am on my way for a RMA ......

    Hopefully it wont take too much time, so frustrating ...

    Cheers ! 


  • Did you fix your soldering or your problem at all? My USB cables and connection seems to be OK, but I got the same problem. Please let me know of any idea.



  • Hi Horia,

    This sounds similar to problems that we had.

    As a test, try to load the code and do a setup using Arduino.

    You can also try to load the PiratesNG code, although that code is limited to just flying, and no navigation.

    If you download and install the code/Arduino, you will find Arduino based examples that let you test each of the sensors on its own.

    Then, if you can return the boards with not too much hassle................

  • 3D Robotics

    If you can connect again via the CLI, do a "reset" in the setup menu. If you can't connect via the CLI there may be an issue with the hardware and you should arrange for a return/replacement from the store you got it from.

This reply was deleted.