Hie all i am currently trying to get my apm rover to work and i have hit a brick wall.I tried everything and i have just about given up. Here is the hardware i currently have

Apm 2.5

apm power module

CN06 Plus

Turnigy 9x tx and rx

Generic brushed motor esc

It has a skid steer tank steering setup. 

Whenever program it to go, it just goes around in circles, with one motor on. When it gets to s certain position (while going around in a circle, the second motor turns on (slowly) and then turns back off. I put in 1's in the SKID STEERING IN and OUT. Nothing is happening.

Any ideas? 

Here is my setup,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Admin


    Try checking the aileron "reverse" box in the Mission Planner Radio Calibration screen.

    Your waypoint radius should be around 1 - 2m and make your waypoints at least 6 - 8m apart.


    TCIII ArduRover2 Developer

    • Thank you it worked! I made a 10x 10x 10 triangle and the rover followed the waypoints. The only problem that i need to sort out is the turning speed as it overshoots and then reverses and goes forward and reverses and goes forward and jitters all over the place.

    • Thank you for your reply. I will let you know of my progress tomorrow morning as it is night time here in Australia. Thank you for your help

  • How small of a waypoint did you make ? Reset all automatic settings because manual works fine, change waypoint to larger scale. Ive had this problem before forget how i fixed.
    • I did one of my back-yard so about a 5 X 5 X 5 triangle.

      I'll go to the park tomorrow and make a much larger waypoint. 

  • How does it work in manual or steering mode?

    • yes it works perfectly in manual mode

This reply was deleted.