Hey ,

 I am trying to control my Rover with a Companion Computer ( Raspberry Pi). I have installed DroneKit Python on the Pi, The commands works fine for a Copter as most of the tutorial says. but they do not work for Rover. 

The Raspberry Pi is getting connected to the Pixhawk, but when the pi commands the Pixhawk to move with vehicle.message_factory.set_position_target_local_ned_encode the Rover dose not move. this worked fine for the QuadCopter. 

Is there any alternative or any other way by which i can control the Rover any help is appreciated.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • The speed issue is solved. The problem I'm having now is with weaving. I'm using a uBlox mounted on a mast and have the internal compass disabled. I've checked for magnetic interference from the motor - it doesn't appear to be a problem. I've looked at some other threads on this problem and checked the suggestions. The only thing that stands out is that I'm currently testing at very low speed -- 0.5 m/s. Any thoughts? Thanks.
    • Your low speed is part of the problem, it has a hard time with low speed driving and keeping a good heading.  I pretty much followed this guide and it weaves once or twice on startup and goes pretty much straight after that.


    • Thanks Ray.  Does the low speed heading problem include not going in the right general direction?  I could understand weaving toward the destination.  In this case, it typically ends up going in no discernible general direction.

    • No that sounds like something else, compass calibration maybe?  When in mission planner and driving around in manual does the compass heading point the right direction more or less?

    • Finally had a chance to do some testing today.  The compass seems to be reasonably accurate when driving manually while connected to MP.

      Also tried a couple more guided mode missions.  It appears that the vehicle is going in the opposite direction that it should.  In other words, heading is off by 180 degrees.  GPS seems accurate -- I have the rover reporting current location every 0.25 seconds and the values get further away from target location.  Very puzzling.

    • Sounds like your compass orientation is incorrect.  I had a lot of trouble with mine.  You may need to change the yaw to 180, or the roll to 180, or both.

  • Hey guys thanks for your replies .... i am sorry for my long absence, 

    I needed the throttle to be around 40% for the car to start moving . 

    as David Mathias  i also faced the same problem of over speed , 

    Lowering the throttle slew rate as  Ray Quintana suggested should do the trick. 

  • Like Akshay, I am coming from the Copter side.  I have my rover setup with an onboard Odroid XU4 and Dronekit-Python.  When I run a simple script to do a single simple_goto, the rover takes off much faster than it should.  In the script I set the dronekit groundspeed parameter: self.vehicle.groundspeed = 0.5   I'd guesstimate that the rover is moving more like 2 m/s.  How can I control the speed?  Thanks.

    • You might need to set the throttle slew rate lower in rover for the taking off issue.  Also there is the cruise throttle, you could set it in rover first then use the same cruise speed in your scripts.

    • Thank you, Ray.  I have the cruise speed set at 0.5 m/s (I want it to move slowly during initial testing) and I think the cruise throttle set to 50%.  Is that a reasonable value?  I haven't touched the slew rate -- it is still at the default.  I'll lower it.

This reply was deleted.