Bear with me if this has been discussed.  The forum search engine doesn't seem to work.

I've got a rover with the latest firmware, GPS, and a 3DR radio link.  I'm able to connect to it fine and upload waypoints to it.  I can see the live GPS track if I drive it around.  I can also retrieve stored waypoints if I shut everything down and power up again.

But, when I click the play button in QGroundcontrol, I get Unsupported command 252.  I also tried the launch button and I get Unsupported command 22.

So, am I missing something?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    QGroundControl is geared towards the PX4Native platform.  APMPlanner2 is your best bet if your after something for APM:Rover as APMPlanner2 was forked from QGroundControl.

    Have a look here :

    Thanks, Grant.

  • Admin


    The ArduRover2 code is somewhat different than the Arducopter code and that is why you are probably getting the unsupported command errors. I am presently using AndroPilot with a Samsung Galaxy Tab 2 and the 3DR telemetry module and am having good success. However there are ArduRover2 parameters that are not displayed correctly and I plan to work with Kevin Hester to correct those issues in the future.


    TCIII AdruRover2 Developer

    • Hi,

      I am experiencing the same issue.
      APM planner works well with APM:rover on Pixhawk, while on Qgroundcontrol I get "unsupported command 252" message every time I try to start a mission. I also tried the launch button and I get Unsupported command 22.

      Any news?

This reply was deleted.