RoverWarning _No Brakes! A throttle nudge story.

While testing my rover recently, I had one of the most counterintuitive experiences in my decade long rc career with catastrophic results.In AUTO, I was tweaking cruise speed while running a looped mission. Naturally, without tweaking steering params the rover would take wider turns as speed is increased.When it became apparent that my rover will not make it's next turn, I tried to slow it slightly to clear the upcoming curb.As it turns out, "throttle nudge" only nudges forward, Even when commanded to slow, throttle increases. I accelerated for the remaining 2.5m into a solid concrete block. The results were disastrous to say the least. The most damage I've ever seen from a single crash, and I launch my rover from 7' dirt jumps regularly. (Occasionally in auto, but that's another story with it's own set of difficulties)I know that braking is fairly new in the rover code, and it's likely that throttle nudge has not been updated to reflect this. I did find mention of "throttle_nudge" in the radio.cpp file (line58), but I haven't a clue how to modify.Any help would be appreciated.Hope this post prevents others from such devastating crashes.Mike

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    This is fixed and now available.  You can either get the latest firmware or I have also created a beta release which includes this fix.

    The latest firmware build of the source code is always available at

    For instance if your hardware is a Pixhawk this is the link you would use.

    If your using MissionPlanner you can go into InitialSetup and select "Load custom firmware" and you should be able to upload it. 

    If you use this you are on the bleeding edge - no promises your rover won't be random ;-)

    Let me know how you go.

    Thanks, Grant.

    • Thanks a bunch Grant!
      Not concerned about running 'latest' code. I've been loading beta for as long as I can remember.
      I'll load and try it tonight.
  • Already reported in Feb last year -

    • Developer

      Thanks for pointing that issue out Mike.

      I have replicated the issue in SITL.  I'll have a fix in master shortly.

      Thanks, Grant.

    • Great to hear, thanks Grant. 

      Once straightened out, it'll give me a little more confidence when approaching obstacles.  This past week I've been overly cautious, switching to manual 5-8 meters early to avoid incident, though I did run under the bleachers again yesterday. Oops!  Thankfully no damage this time.

      Thanks again,


    • Developer

      My personal approach is to flick a switch and go into HOLD mode rather then MANUAL.

      I'll let everyone know when the code has been updated.

      Thanks, Grant.

    • Admin


      From a couple of years of Rover testing experience, I have to agree with Mike Rover that switching to the MANUAL Mode and applying full reverse throttle is the best way to go in relation to going to the HOLD Mode.

      The change from the AUTO Mode to the MANUAL Mode is extremely fast and being able to apply full reverse throttle has saved the bacon in many instances where the rover was headed towards an immovable object:-)



    • Will HOLD apply the brakes?
      I haven't had HOLD on my mode switch since '13, pre-brake.

    • Developer

      No - it won't apply the breaks - yet :-)

      Thanks, Grant.

    • Take this with a grain of salt - I haven't looked at the code in almost a year.

      Hold sets throttle to RC_TRIM. That, in generally, wouldn't apply brakes but would depend on the ESC, usually it will just set you to "idle".


      My understanding of ESCs is that if you pull back hard in manual mode it may well slow you down faster. If you set up HOLD to go full negative throttle (which would give you braking) you'd run the risk of flipping to full reverse.


      A flag to select "HOLD" as RC_MIN or RC_TRIM would be helpful for anyone running a non-ESC braking system (I think the FarmDogg people have a system like that) - HOLD at RC_MIN would apply full brake. 

This reply was deleted.