Black Pearl rc801 Battery not working

My Black Pearl monitor has worked flawlessly for almost a year. And then the battery stopped working.

So i purchased a new battery; and lo and behold, it doesn't work either.  

The monitor turns on with the charger plugged in, and the red charging light illuminates. But when the charging light goes off, signaling the battery is full, and i subsequently remove the charger, the monitor will not turn on with the battery - either the old battery or the new battery.

I found a few people with the same problem discussed in the Amazon question section, but no one had a solution. 

Does anyone have any suggestions...?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Imho, this is definitely not a battery issue, but something internal to the monitor.

    Fortunately for me, the vendor where i got my Black Pearl,, is taking back the faulty monitor and sending me a new one - thanks Adam!!!

    • Regardless Steve... end users as QA is a rather common Chinese manufacturer practice unless the US designer has specified a test step in the manufacturing process.

      For instance, my Lenovo ThinkPad Tablet, much ballyhoo'd by Lenovo in Spring of 2012, arrived with the unit not completely snapped together, and unable to boot into English.  I had to go online to figure out Android settings screens, as I had never seen them before.

      As well, there is a big market in the Far East for recovering and re-using electronic components, and I really hope some of these items haven't gotten sourced into APM and Pixhawk autopilots. My Iris had a gyroscope glitch and crashed itself hard thru a tree.   The gyros are solid state, so through normal production QA, bad components are tossed.... hmmm.

  • I had a similar problem - out of the box, the installed battery worked fine, charged-up etc.  The supplied backup battery, DOA..wouldn't charge, hold a charge or do squat.

    Had to send the whole unit back to the vendor: in this case 3DR.

    My suggestion?  How about enforcing a set of Quality and Performance Measures on the manufacturer, or find another, say in the US?  Wouldn't that be a novel concept.

  • I just powered mine on, then plugged an unpowered charge plug in and it did not shut off. So there doesn't seem to be a battery disconnect in the charge port. Could you check for voltage at the battery pins?

    • Thanks Tim. My voltage meter pins aren't thin enough to fit in the battery slots. But i'm sure it is not a battery problem, between the old one which was working fine, and now the new battery.  It's got to be something internal that is not allowing the battery to connect.  I left a message on FlySight's fb page, hoping they will respond with a solution.

  • I have the 3DR version with two batteries. I have the same non-charging issue with one of the batteries, while the other one charges and operates without external power just fine. Definitely seems like a battery issue, bummer your replacement one didn't work. I haven't explored the issue further than that.

This reply was deleted.