Hello all,

I've had an IRIS+ for about 2-3 months, but bad winter weather where I am (western NY) has limited me to only about 3 days of flying. -- So I'm very new to all of this, but I love it!

Problem that just surfaced:

Tried to fly IRIS+ a few days ago,  and could not get green blinking light-- only double yellow.  -Hooked copter up to Mission Planner  using Radio link and the voice and screen status in Mission Planner say: "compass not calibrated".  I tried calibrating compass under setup///compass calibration/Live Calibration... but the box with the x,y,z axis does not move or record any "white dots" when I move IRIS around as directed--  What am I doing wrong??

--Also, I thought IRIS+ would do it's own compass calibration using GPS data when powered up (it does get a good GPS fix on the radio controller), but I've waited 10-15 minutes on multiple tries, and I still get the blinking yellow and "compass not calibrated" message.

--Thanks for any and all help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • To get a current log of what's happening we need to disable the pre-arm checks:

    ARMING_CHECK = 0 (disabled)

    With the props off arm the copter and raise the throttle a little.  Then lower and disarm the copter.

    set ARMING_CHECK = 1 (enabled)

    Upload this log to see what is and isn't working.


  • Looks like something not right here.  There are two compasses in the IRIS.  One on the GPS and one built in to the Pixhawk.  So you should be seeing two axis being calibrated when you move the copter around.

    You say you don't see either one moving.  That's just not possible since they are both hooked up differently.

    Do you know what version of Firmware you are running and what version of Mission Planner you have?


    • Bob,

      I have never needed to do a compass calibration!  BUT, it sounds like you may be having the same problem I had when I started out! When you connect the battery, DO IT QUICKLY, and DON'T TOUCH the bird again until you have the green light. If you giggle the bird at all while it is doing its system checks you will get errors.

    • Michael,

      I do see two sets of xyz asis when i hit the "Live calibrate" button, which makes me think that MP is sensing two compasses-- but when I pick up the IRIS and move it around to calibrate the compasses (like it shows in the 3dr video) I don't get any "dots" populating the sphere around the three axes as occurs in the video.

      My Mission Planner is version 1.3.19 (build 1.1.5508.10848).  I don't know the current Firmware version of the Pixhawk, but it's about 2-3 months old.  When I connect MP to the Pixhawk using MP with the telemetry radio- I get a message box saying "New Firmware Available: Arducopter v 3.2.1 Please upgrade".  I haven't upgraded this yet.

      Jack-- I've read a lot about not moving the IRIS+ immediately after plugging in the battery and I'm REALLY careful about that-- I usually don't even close the battery door for 5-10 min. -- but I still get the flashing double yellow light and MP says "Compass not calibrated" in voice and red lettering over the artificial horizon.

      Thanks to both of you for responding--


    • The current Mission Planner is 1.3.23.  The firmware you are running may have some bug in it and I would recommend updating it.

      However that does not seem to be your issue here.  Mission Planner always displays two xyz axis as it assumes you might have two.  Still need to determine why yours are not showing up.

      You should have an old log still on the copter.  If you can hook the unit up with a USB cable and download the last log we can maybe see what you have.


    • Michael,

      I just updated Mission Planner to v. 1.3.24 and I still get double yellow light blinking on IRIS+, and the HUD in Mission Planner says "Prearn: Compass Not Calibrated".  I'll get a log from MP and post it.  Might take me a while-  I haven't done this in a while--.

      After downloading the newest version of Mission Planner, I tried to calibrate the compass again, but the calibration still doesn't work.


      I have not yet updated the firmware in the Pixhawk.  In fact, I'm not sure what version of firmware is on the Pixhawk at the moment.  Mission Planner is prompting me to update the Auducopter firmware to v 3.2.1  but I haven't done that yet-- thought that might complicate the issue--

      -Thanks for the help-

    • I have a newer and an older Pixhawk. The older board did not have a problem with 3.2.1. The newer board is not flyable with the new version 3.2.1 What I had to do is reload ver. 3.1.5. Are you getting "PreARm: Compasses inconsistent" on your HUD? I think there is a problem with the boards that came out from Aug to Dec of 2014. Autotune is the last thing you want to do. That's how I solved mine. Good luck

    • Bob, when connected to Mission Planner, does the HUD show movement of the quad? I've also read that the Pixhawk calibrates itself, but I've also read to do the calibration until you have 2 SOLID filled spheres. I did that yesterday with my second Iris+, followed by an "autotune". Very entertaining, these flying gizmos, with what is "I" believe to be controllers from another planet! We humans are just too plain stupid, to create such devices. But this is coming from a 65 year old, that can still remember the invention of color TV, and cell phones! Ha! Got any 8 track tapes laying around? ha ha ha

    • lost all my old 8 tracs when I got flooded in Hurrican IKE in 2008. Still got the 8 trac player from my AMC gremlin in 1976 but I'm still not old as you:)

    • Hi Steve,

      Yes, the HUD in Mission Planner shows movement in all axis when I pick up the IRIS and move it around-- including changes in compass direction!  I wouldn't mind doing the calibration until I got enough data points to give me almost SOLID spheres-- but during the calibration, I get NO white dots--and the message counting up data points does not increase.  It seems clear that MP is not receiving data points from the PIXHAWK or, at least, not displaying them while I'm moving the IRIS around to try to calibrate it.  So you're 65-- well I'm 67, I should give this problem to my 5 year old granddaughter!  BTW what is an "autotune"?

This reply was deleted.