IRIS drifting in loiter, yawing, no low battery warning

Very new to this, but there is a time for firsts...

Flying my IRIS for about 2 months now - very happy. Told myself to make quite a number of "flying hours" first before trying things out with Mission Planner. Want to be able to fly the thing myself if the electronics goes bad. Consequently had to replace a propeller and a motor at some stage - had to learn soldering. But this is all great fun really !

Recently started flying missions with Mission Planner. Works fine, very excited about the possibilities of the software.

Also installed new firmware - upload to pixhawk went fine. Then I thought while I'm at it - let me just complete the Mission Planner Setup Wizard. Selection of frame layout, calibration, etc.

I think I should not have done that. Afterwards also saw the recent update on where it says no software setup is needed.

Also had to fasten a motor again to the arm - after the heli flipped over recently, the internal thread on the motor was damaged. So I used the longer screws included with the heli. Tried to limit their penetration into the motor with a plastic washer - see photo.

Now I have the following issues:

1. When flying in Loiter mode, the heli drifts away. Only able to get it back in Altitude Hold / Stabilize modes.

2. When activating Return to Launch, the heli does something, but it's not return to launch.

3. When flying in one position the heli slowly yaws either left or right.

4. The LED flashing and beeping tone when the battery is low does not work anymore. LED stays green, without any beeping tone. I made it a custom to set a timer to 12 minutes to avoid getting the heli back from a far distance on low battery power, so it didn't crash luckily.

Before completing this Mission Planner Setup Wizard, Loitering and Return to Launch performed perfectly, also had no yaw issues.

What should I do to resolve these issues? Is it possible to do a factory reset on the heli?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • one important thing for loiter and also for return to launch to work correctly is to have a very good gps lock before arming the iris, using mission planner or your ground control station software of choice, you can view the accuracy. on the flight data tab,  looking at the HDOP, it should be below 2.0 before you arm the iris to use RTL and loiter, the green flashing light only means you have a 3d gps lock, not a HDOP of less than 2.0.

    like mentioned previously, **dont run the wizard**

    goto initial setup, install the most up to date firmware

    after the firmware update is complete, connect to your pixhawk in the upper right, then go through the mandatory hardware setup

    select "V" for the frame type, then on the pulldown on the right, load the iris.param, it will show a screen comparing your current settings to the iris.param, i would select all of them to load all the iris parameters 

    after that, calibrate the compass and accelerometer and check your radio calibration and failsafe and you should be all set. 

    • Just to make sure - this is the screen I get following your instructions (see picture):

      3702489318?profile=originalSo on the left we have the current parameters, and on the right the default IRIS parameters? So if I click on Continue, the IRIS parameters will be loaded?

    • Correct
    • @ SteveL, Jordan Brown,

      Thanks for tips. Flew my Iris again just now and all was well - loitering, RTL, autonomous mission. Will keep checking the hdop < 2.

      @ Christian Elsen,

      I tried to find these logs, but was quite difficult - didn't find them in the end. But thanks for replying anyhow.

  • Dirkie, I wrote about the 'no low battery' issue here:

    Here's the steps tech support walked me through to load initial parameters:

    1. Connect IRIS to Mission Planner
    2. Initial Setup
    3. Mandatory Hardware
    4. Frame Type
    5. In the pull down menu choose: 1) IRIS or 2) IRIS w/ Gimbal if you have one.
    6. OK, and it loads instantly.

    This also solved my Loiter drift mode.  Although yesterday i had it spontaneously drift in Loiter again, which just missed a telephone wire (5 seconds of panic!).  So i'm not sure now what will solve the Loiter drift issue... anyone from 3D Robotics listening in with a solution...???

  • Do you have a backup of the configuration (parameter file) from before you ran through the setup? Then you just need to recover the settings from that file. 

    Otherwise: IRIS was flown at the factory. So recover the configuration from the logs of that file:

    - Download the log file from the first flight of IRIS (If there were multiple flights on that same day, pick the latest one instead).

    - Open the log file and remove everything except the PARAM sections.

    - Remove "PARAM" and commas in the remaining file, so that it looks like a parameter file

    - Upload the file as your new parameter config file into IRIS. 

    The result will be that IRIS will behave exactly as when you received it from the factory. 

This reply was deleted.