IRIS Field Test Trouble / Failure Reports

 I have noticed scattered reports of IRIS hardware and software failures. Given the fact that The IRIS is a new design and we are field testing it now; it may be  helpful to both the our community  and 3DRobotics if we establish a place to document unusual or unexplained problems with our IRIS ( "?IRISes... IRISis?). 

Here is my first report:

I have a question: I have a new IRIS and I had some issues getting the Quad up and running. I started with fully charged batteries, and performed the pre-flight check. All was well. I saw the solid green LEDs and commanded the bird to arm....nothing....I repeated the procedure about 10 times connecting and disconnecting the battery. I received no error signals. Then on about the 10th try the IRIS armed. This suggest either a software issue or a hardware QA problem. Has anybody else experience these intermittent failures?
I think we need to keep 3DRobots informed of the field testing done on their product.

Since the IRIS does not have a QA inspection sticker on it, it is hard to gain any insight into the pre-shipment process. I would like to know if they shake test the IRIS before shipping...

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • You didn't inadvertently ARM the IRIS with the safety switch while it was on its back did you?  The Tarot gimbal power wires are very fragile. We always add some hot glue around the wires were they are soldered to the gimbal board to add some rigidity.  Have you powered the gimbal separately with another battery?

    • It is possible that while it was on its back it armed.

      It did not make the I'm being armed tweet noise...

      I have not tried the gimbal with an external battery, as I don't know what voltage battery it wants....

      When I tried checking to see if the gimbal battery connector was directly connected to the main battery connector with an ohm meter, it was not directly connected, the power leads seems directly connected, but the ground leads did not. So maybe the whole issue is the gimbal had no ground.

  • I just got time to fly my IRIS for the first time about a week ago.

    It flew just fine right out of the box....

    I only flew it twice  and thought I really need to get a gimbal for it....

    So I ordered the tarrot gimbal from 3DR and installed it and my gopro...

    I then went otu to fly it and the gimbal was dead, no lights, no activity at all no response to the tilt on the RC transmitter....

    So I figure maybe its not getting power....

    I disarm the quad, put it away and take it inside to debug later.... (I only had about 10 minues to play with it)

    Tonight I figure I'll diagnose the gimbal  

    So I power it up on my work bench (its not armed)  and see no activity at all from the gimbal...

    So I flip the quad over on its back to carefully look at the gimbal to see if maybe there was a power switch or something....

    I see no swithch so I get my voltmeter to measure the voltage to see if the gimbal is getting power... 20 seconds later when I look back at the IRIS  the unit is smoking  and the lights are all dead...

    I  flip it back over so I can access and and unplug the battery, now its dead with or without the gimbal...

    Very disappointed, waited months and months to get my unit, I've played with it less than 15min and  now its dead.

    Clearly there are quality teething problems at 3DR I hope they can get it working....

    Anyone have similar issues?


    • Haven't had any issues like that yet.  Did you figure out what was smoking?

  • What I am having problems with the most is inconstancy. I have been only looking to do little test flights, not high on alt hold just hovering of a 3 yrd area.


    3 times out of 4 no problems but 1 always seems to be a little off, wobble, need more throttle to take off, lots of movement without wind.


    I am fairly uneasy about really taking her out for a good fly...  

    • Moderator

      Fly it in a wide open area and left and sit at say 10 foot to get out of ground effect it will be much easier.

    • Thanks Gary.


      I do notice the times I seem to have issues the motors do the arming spin and when I give it throttle I get the initial "whirl" of power (sound) without lift until I really push the throttle, Maybe I am getting a lot of wash due to the additional power..


      Other times she just lifts off..


      I am committed to Iris with all the giblets I have bought !!

  • Maybe you happened to adjust the trim control on the throttle?  That's what ended up being the issue with mine, as outlined in this thread. My IRIS would not arm. As cctaylor410 explained, if you adjust the throttle trim above (ch3in) above the value of ch4out, the IRIS won't arm. In general, I've had a lot of trouble finding any IRIS troubleshooting info except on the forums. But luckily, other users have been very helpful.

  • GByron,

    Did you ever get a fix for the above and what did it end up being?

    Also are you still documenting the issues?

    • Hello Helicopter: Sorry for the delay, I did get the problem solved . I believe it was the configuration of the transmitter. Once I confirmed that the transmitter was on the correct model the arming problem was solved. The FS transmitter can have multiple models and I suspect mine was changed between the time it was tested and the time I tried to fly. 

      I have had several nice flights with my IRIS and all in all I am happy with the device. I have to say that this is not an open the box and it flies. There is a learning curve steeper than that of some other RTF Quads,BUT the IRIS can become an autonomous flying robot and isn't that what we really want?

This reply was deleted.