Iris+ takes flight then lands itself thrice

I am looking for some  help. i had a couple pretty horrific crashes within the week. one broken arm multiple props bent. anyways I connected to Mission planner, BTW installed a new arm and flew it later that night just to make sure  I had repaired it properly. Iris was flying and maintaining hover at that point This was Friday night when all this happened.

I've downloaded the logs but don't understand what i'm looking at could some one please help.!!!!!2015-03-21%2013-57-50.rlog 2015-03-21%2013-57-50.tlog

Also as i sitting here typing this I plugged in the iris and everything seems normal at first then i started hearing this ringing about 9-10 beeps consecutively really fast, then a pause then repeat when it finally did connect with mission planner, mission planner has fail safe written on my virtual horizon....

Whats Going on??????????????

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Kevin,

    I'd really like to know what throttle parameters you ended up adjusting to resolve all your problems. I am having a similar issue.

    • I cant remember exactly at this point what the number was and what I changed it to. If you follow the previous posts there's ascreen where you can change the parameters. Im sorry I haven't really helped
    • No problem. I think I got the problem figured out. Unfortunately, it led to anothe rissue which was totally unexpected. I have posted that story under a new topic.

  • Also in the Full Parameter List there is a pull down on the right hand side of the screen.


    If you select "3DR_Iris+.param" from the list and load that it should put only the values for IRIS+ back to default.  I think it does display a list of parameter that are different and you can pick and choose which ones to load.


    • Ok so updated the fs batt info. No more low battery however as i go to arm it, press the red button on top of the iris, makes the noise saying everythings good, then go to arm the iris and  is says mode not armable, now i noticed a difference , before I updated the firmware it used to say lock alt hold, now it says drift. I moved it to loiter and it armed. I assume this is in the iRIS+ param settings?

    • Yes, the file you sent me had some strange flight modes. You should change them to what was on the previous page for Flight Modes or use the 3DR IRIS+ param pull down.


    • Id did change them. Now it arms and I can get the iris+ to spool up the motor i increase the throttle but it wont liftoff the ground. Normally as i get to half throttle it will  typically really wind up to take off. Now I can go full throttle and the props never put it in the air..... I feel lie Im so close to getting it back up and running! 

    • 3D Robotics

      Do an ESC recalibration and make sure the props are on the right arms ;-)

    • So i tried the esc calibration, I could get the motors to spool what i believe was at full throttle before exiting  the esc calibration.. Unplugged to turn off calibration. Arm iris, goes through normal setup and then, same results. will not gain any more throttle then if it was a notch above bottom dead center...

    • Also tried going through the loiter mode, speed increased a little. went to auto mode and motors spun all the way up like the should... any thoughts?

This reply was deleted.