Good day folks!

Does anyone have an idea of how to reset the Iris+ transmitter back to factory defaults? My transmitter was working great and I have no clue what my kid changed (he was clicking random buttons), but the transmitter is no longer receiving telemetry data from the Iris+.

Any help would be much appreciated,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • For anyone who may have the same issue I found the solution to the problem at the link below. I set the parameter to 2, clicked save, disconnected and reconnected power to the Iris+ and telemetry is now available.

    Joined: Thu Mar 06, 2014 2:00 pm
    Posts: 352
    Location: Wisconsin
    In Mission Planner, once you connect to your copter. Click on the Config/Tunning icon.
    Then click on Standard Parameters and make sure the check box is set next to the Advanced Menu View.

    Then click on Full Parameter List. Click Ok to the Raw Parameter Warning.

    Scroll down to the "SERIAL2_PROTOCOL" and make sure it's set to 2 or 3. Mission Planner says its 2 and the wiki says its 3.

    If you change something make sure you click on Write Params or it won't be saved to the copter.




    • I know this is an older topic, but I just had the same issue with my Iris+.  I turned it on and had no telemetry on the hand controller.  

      I hooked up to Mission Planner, reset all my settings, loaded the Iris+ param file in the setup screen and even went through all of the calibration and setup via the wizard...... still had no telemetry data coming in.  I tried the above suggestion for changing the SERIAL2_PROTOCOL to 2, then 3, then back to 1.  I repeated the reset process a few times.  I was pretty frustrated and turned everything off and walked away for a bit.  

      I came back about 10 minutes later, turned the drone on, looked at the controller and there was telemetry!  I have no idea what i could have done to correct it, so i am not offering much help here, but resetting everything and going through all of the calibration seemed to do "something".  I would say that during the whole process i never pulled the power on the drone, so that could have been a step that i needed to take to get it all working again as well.

      Anyway, just thought i would chime in and share what i did to get my telemetry back up and running.  Hopefully it will work tomorrow again!

  • You probably had a wifi interruption. ...hold down little white button on back of controller for a few seconds. It should link right back up like min did when I had that problem
    • 3702571549?profile=originalThis is what I'm getting. I tried the white button on back, but still getting the same result.

This reply was deleted.