Iris+ wont take off without flipping forward

I have a new iris+ when I first got it, It worked great, I have since crashed it through a tree and broke a arm. I have since replaced the arm and recalibrated the compass, the esc and the accel. I believe. I use MP2 which works great but after the calibration my iris just wants to flip forward and or hinge on the front right leg. I want to attach my log files just dont know where and how to attach in here, Any help would be greatly appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • The video is private.

    If the slow motor spins freely then do another esc calibration following these instructions

    All motors not starting at the same time is not something you want to fly with.

    If the motor isn't spinning freely then either clean it or replace it.


    • oops, its no longer a private vid. cleaning? how to? I read the link you provided Mike, Thank you. Ill try that tonight when m back with the IRIS

    • I'm only recommending cleaning if the motor doesn't turn as freely as the others or if you can feel grit when you try to spin it by hand.

      To clean you're going to have to remove it from the arm by removing the screws at the bottom of the motor mount.  Then once it's off, flip it over and look at the bottom.  You should see a tiny c-clip holding the motor shaft in position.  Carefully remove that clip.  I typically do this over a towel or something so that it catches the clip so that it doesn't fly off someplace. :)  With the clip gone you can pull up on the motor housing and it should come right off.  Obviously there are magnets in there so you'll have to pull hard enough to overcome their attraction.  Be very careful that you don't crush or damage the housing.  It's only aluminum! 

      Once the housing is off you'll see the magnets.  I usually use Q-Tips to brush everything out but have been known to use tap water or even an old toothbrush.  Periodically check to see if the grit has been removed by placing the housing back on and seeing if it spins freely.

      Once everything is clean and spinning freely I usually put a drop of lightweight oil on the bearings.  They're sealed so you won't really get any into them I don't think but it does help with reassembly.  I usually use sewing machine oil for this.

      Put it all back together in the reverse order and be careful with that c-clip!  It's really easy to have that fly off in some random direction!

      I really think an esc calibration is going to fix this issue though.  Follow the instructions on the page and I believe that everything should be fine.


    • Great news, cleaning the motor worked fantastic!!! got it back up in the air. was very cautious and kept over grass and fairly low altitude.

      2 full flights second with gimbal and gopro no problems.

      However now im having an issue with the gimbal tilt function. the gimbal stabilizes and then rotates the gopro to facing backward and upside down. Treid to recalibrate the gimbal any thoughts?

    • There have been a couple of threads on the gimbal.  They should be able to help with that.

    • Thanks guys!

    • Great!  Glad I could help out.

      I was looking for this thread to see if you had any updates but lost track of it.  Glad you're getting your motor issues resolved.

      I have no advice on the gimbal as I'm just now attempting to get mine up and running.


    • I will defenitly try that once im back with the iris tonight.

  • Your going to look at the RCOU parameter and see that all the motor are getting the same thrust. If they are then the problem is the motors are not spinning up the same.

    You need to do this in stabilize mode to rule out position problems.


    • Thanks Michael, Do i look for the RCOU parameter in MP2?

This reply was deleted.