RTL not working as advertised...

Hey guys, yesterday I had a scary situation.  A had the IRIS + in Auto mode and when completed I switched to STD and signaled for RTL.

At that time the quad was only about 20 M from me (x,y,z).  As soon as I switched to RTL the IRIS took off in the opposite direction and elevated to around 100 M.  So it was several 100 Ms (x,y) from me and 100M in the z direction.  

I thought for sure it was gone.  Eventually, after several minutes it slowly came back and landed at the original launch location.

Any thoughts? I was using droid planner but I am not sure how to get any info off of that app to see the logs ( I am still kind of new to the this)



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • thank you so much for all the help.  I have one more concern about my upgrade.  I have been having issues with my compass offsets.  I have included a picture of my pixhawk connections after the upgrade.  I fear that I dont have the compass in the right 4 pin connector.  in the video it states that you need to put the compass in the I2C connector. but this is not how I had it connected before the upgrade, you will notice that currently the compass goes into one of the 4 pin ports to the side of the pixhawk.  Does this look correct? Currently I have the i2c port connected to the side.  

    If you have a chance can you take a look at the picture and tell me if this looks correct?


    • Looks good.

    • thanks so much, last question, any danger in ignoring the compass check during the preflight arming? it wont arm with it currently enabled, and I am not really sure why the compass is failing the offset calibration.


  • When you followed the video to do the upgrade at the end it showed how to load the parameters at about 19 minutes.


    your picture is the original modes.

    It should be Alt Hold, Loiter, Auto, RTL, RTL

    This will also change switch 7 to be Land.


  • As Michael rightly said you never switched to RTL but you went from auto to stabilise mode and because your throttle stick was more than hoover the quad kept going up till it reached the 100 meter fence and subsequently went into RTL mode (by itself as a setting of fence breach.

  • Dude, you are running 3.1.5 on an IRIS+ and the switch position for STD is not Standard. It turns into Stabilize which because you had the lift just above have way means to go up.

    Luckily you hit 100m and the copter switch to RTL and came back.  This thing could have ended up in the river.

    You need to put 3.2 back on this copter along with the IRIS+ configuration.



    • ok, so, to be clear.

      I received the Upgrade Kit, went through the upgrade but failed to update to 3.2 during the process.  So, even though I was using the new stickers on the rc the flight modes where still using 3.1.5? 

      So, when I hit STD and RTL, what actually happened? Sorry, still new to all this...

    • Yes, this could be an issue with the IRIS upgrade.  If you don't load the IRIS+ parameters which change the flight modes for the transmitter you will be in the old modes which is just Stabilize and the RTL switch will do nothing, as was the case in the original IRIS.  To use RTL on the original IRIS you need to be in AUTO and RTL.

      You need to load the IRIS+ parameters to change the Modes to match the sticker.

      You should also verify this in Mission Planner under Initial Setup/Flight Modes.

      I did the upgrade kit but I left the sticker off and left the modes the way they were.  I've been flying that way and didn't want to be confused with the new modes.


    • thanks so much.  How do I find the IRIS+ config in the flight mode section.  All I see is what I loaded as a screen shot


    • see pic

      Screenshot (56).png

This reply was deleted.