Strange gimbal tilt behavior.

I recently did some flying without my tarot installed.  I have re installed the gimbal but now the tilt is acting up.  The tilt works as expected in ALT_HOLD and POS_HOLD, but when I switch into AUTO the gimbal tilts back up to looking straight ahead.  If I switch modes the tilt goes back to working again.

I don't think the logs would show anything but I can link to one if needed.

Any help would be appreciated.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I think you might want to include your params in addition to your logs. For example, what is rc9_function set to? I'd recommend packaging that all up and emailing 3DR support.
    • RC9_FUNCTION=7


      2015-02-20 17-47-15.param

    • I meant to include parameters AND logs. RC9_Function was just an example to look at. Mine is mount_tilt as well.

      Have you tried uploading an empty mission to the Iris+. One devoid of any way points or ROIs?

      Aside from the logs and params, another useful bit of info is what if any ground station you using in the field?
    • I originally saw the problem after creating a survey mission in the latest version of Tower on my phone. When it first started, I was unable to control tilt in POS_HOLD or AUTO.  I have deleted the mission and created a survey in Mission planner.  Now I can control tilt in POS_HOLD but still not in AUTO.

      Ground Station=Tower

      I have attached the .bin file since the .log is too big to attach.



      2015-02-20 17-39-24.bin

    • Did you try it with Tower disconnected/Turned off.  I have seen with some Tablets/Phones that the ROI function will be messed up with some of these units.


    • Will try that shortly.


    • Well it looks like Michael is correct.

      The same mission that I was having the tilt problems with works perfectly if I don't connect Tower.  I will try Droidplanner 2 later on today and report back.

      Thanks Michael


    • Yup. I haven't done a survey, but have a somewhat related issue with follow me guided mode. In droid planner 2, if I do follow me, I lose control of the gimbal tilt function even after the follow me session is over IF DroidPlanner is still connected - regardless of what mode I switch to. The only fix is to disconnect droid planner. Since I need DroidPlanner to fly (i rely on its voice notifications) my solution is to power cycle my android phone to kill whatever process isn't being terminated correctly. Then I can reconnect with droid planner and all is fine. Im in a rush, so I don't know if I explained all that very well, but i suspect that if you power cycle your android, you'll be able to relaunch droid planner and reconnect to the drone and have tilt control.
    • OK here is what I come up with.

      I believe there is a bug in Tower.  As soon as I connect with Tower the problems begin.  Sometimes I lose tilt in ALT_HOLD and POS_HOLD and always in AUTO.

      I can disconnect Tower and connect with Droidplanner 2 and everything is fine.  Everything works fine without connecting to any ground station as well.

      Many thanks to Erik and Michael.


      Tower Version 3.1.3

This reply was deleted.