Has anyone had any experience getting this APM2 Simulink Blockset to run on their APM2.x? (2.5 or 2.6) The link is :


Have you had any experience or heard if anyone who has worked with this before? My main concern is whether it is safe enough to use without damaging the board when downloading code onto the board. Also, is there a possibility that the dataflash or relevant hardware could be damagaed by the.burning process? I'm trying to finish up my thesis by end of the year so I'd greatly appreciate any feedback.

So far, I was able to get it to download code on my APM2.5 but couldn't get it to run normally. Also, my board showed the error"No dataflash inserted" after I downloaded the code, so that might be caused from running the APM2 Simulink Library, but unable to confirm. I believe that this is a fatal error for the board and it needs to be replaced. Does anyone else have any experience with this software set or getting this error after flashing new firmware? Thanks.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Alex 

    I use that blockset with APM 2.0 and APM 2.5. What I did was just collecting sensor data and pilot inputs for system identification though. I didn't get any error and it worked really well. Only thing didn't work for me was the accelerometer in APM2.0 always gave out 0 while it was moving but it didn't happen when I switch to APM 2.5. 

    Right now I'm working on embedding a stateflow model that will send sinusoidal inputs to implement more precise flight test maneuvers.

    • Hi guys,

      I've been struggling with the APM Simulink Blockset for a week without any results. I get a compile error in both 2012b and 2013a, XP 32 and Win 7 64.

      Oliver, did you just follow the blockset installation guidelines? Did you use the Arduino or the Ardupilot IDEs? What version? I think you have to use Ardupilot IDE 1.0.3 and rename it arduino-1.0. Is this correct?

      Also, what kind of compiler did you use? I have issues with both the SDK 7.1 and MVS 2010.

      Would it be possible to outline the installation process?

      Thanks so much for you input, as I'm really frustrated trying to make it work. It seems like a really great block set, if you manage to install it properly...



This reply was deleted.