I have built a S550 Hex running Sunnysky 3108 720kv motors.  I have a UBEC in channel 8 and all ESC's have all three wires connected to the Pixhawk. My Pixhawk is brand new.

The Spider 30A ESC's calibrate fine and do not exhibit any throttle issues in the calibration mode, I have heard a short grinding noise from one of the motors which leads me to think I may have a sync issue as well?

When I arm the Pixhawk and throttle up, the throttle doesn't respond to my input but instead starts a slow ramp up that doesn't seem to be responding to any of my adjustments, just a slow ramping up. 

I am getting very frustrated trying to get any ESC's to work with my Pixhawk. I have tried generic simonK ESC's, HobbyKing 20A UBEC ESC's and now these Spider OPTO ESC's, all of them have calibrated fine only to exhibit a variety of sync and throttle issues when armed. 

Any advice would be greatly appreciated. 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • hello Tim,

      May be you should go thru the wizard, sounds like you radio is not set up correctly. It easy to find out if it is your radio or ESC . Just remove one other ESC Leeds from the PiX Halk and plug directly in to the receiver throttle channel then power up the copter and raise the throttle if the ESC / motor connected to the Rx throttle spins up then you know ESC is good! then you need to look at the radio  . Please be aware that there are 2 different setup for 9X one for heli other for air plain I recommenced air plain. https://www.youtube.com/watch?v=xGUrBbM_JKs


    • Update. I have solved the major issue with my Pixhawk working with my ESC's, for some reason the THR_MAX parameter was defaulted at 80, instead of 1000. Changing this has solved most of my problems. I am still occasionally hearing a grinding noise coming from one of the ESC's. Doesn't happen often and when it does its a short grinding noise. I have read that changing the RC_SPEED parameter from 490 to 200 solves the problem?  Any insight on this issue?

    • All ESC's calibrated fine through RX throttle channel. Perfect linear response to RX throttle. I am using the SBUS, is there something there that could be causing this? My RX calibrates fine with MP and also works fine with an APM 2.6 quad I have.

      I have tried varying the RC_SPEED settings from 490 - 100 and nothing works.

      I also re-flashed the board using the wizard in MP. Half way through the wizard setup I had a screen that had what looked to be motor configuration options, there wasn't a hex option but I'm assuming that screen was asking about X vs. Y and other configurations. I selected X, which had an image of a quad layout, seems a little confusing

This reply was deleted.