My Pixhawk telemetry does not show Voltage level

My Pixhawk telemetry shows a lot of things, but not voltage, current and % of battery used as it does in my Ardupilot piloted quad. I did the following to check this:

- it happens in mission planner, APM planner 2, tower and droidplanner (both versions)

- I swapped the power module with that of my ardupilot, same result

- I swapped the Tx/Rx modules with that of my ardupilot

- Armed and disarmed does not matter

The swap with the Ardupilot hardware was done because that configuration worked.

Anybody any idea what is wrong? Should I go for a new Pixhawk?

Thanks in advance,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • And I found the error! It was a very noob mistake: in order to receive telemetry feedback of the battery status you need to have enabled it in mission planner. I did so and it works since then. I am sorry to have bothered you with this, but thanks very much for your support!


  • What type of RC transceiver are you using? You could possibly get these settings through the telemetry on the remote control

    • Thanks for your suggestions Keith. For the telemetry I use 3DR telemetry radio and I use the Taranis FrSky. For my Ardupilot i use Roilf Blomgrens solution ( to send telemetry back to the transmitter. I will implement this as well for the Pixhawk, but as there is no electricity info in normal telemetry, I hardly expect it to see via other means. It has to be sent via Mavlink and as the other information is sent back correctly, the electricity info is simply not present. And I just wonder why.

  • Just to be clear, you tested your PM on a different system (ardupilot) and you got readings with that PM, right?.

    Is your PX4 made by 3DR?, if so while you ask here you can ask them, even when then not respond within the hour they will answer between the day.

    • Vice versa, i took a working PM from my ardupilot and connected it to the Pixhawk. I also took working telemetry tx/rx from my ardupilot and connected it to the pixhawk. 

      It's all 100% 3DR. I did already ask, but i asked here because they didn't answer between the day :-). I asked 1 1/2 days ago.

      Thanks for your help!


This reply was deleted.