Pixhawk Copter "Bad Accel Health"

I’m going to setup the Pixhawk now, but I continue to receive errors of "Bad Accel Health" or “inconsistent compass”. I'm doing the setup indoor.
I already updated the Firmware (with Craft and Theory build for the telemetry cable, but the issue was the same before this flashing), and I also already re-calibrated the accels, but the issue is still present.
Do you have any idea about what could be the problem? Could it be a hardware problem?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • "The strange thing is that the Mission Planner reports the calibration is successful".

      Yes, that's right, and that's why I suggest ignoring the audibles and continue forward with working through the list of calibrations.  That's what I DIDN"T do for so long.  I just felt stuck!!  I spent hours on the phone with 3D Robotics and even had them convinced it was a (new) out-of-box "defective" Pixhawk.  Yes, they sent me a new one (for free) before I had even returned the "bad" one.  But, same problem with the replacement one they sent me.  I thought I was creating the problem....damaging the Pixhawk.... by using clone components such as a power module for 6s batteries and the Ublox M8N GPS/compass puck.  So I went back to the very basics....all 3DR components.....connecting one at a time.  But when I saw I still had the same problem....now on my 3rd brand new Pixhawk.....and I noticed on MP, "calibration successful"....is when I started to ignore the audibles and just keep going.

    • what firmware version are you running ? How cold is outside and how far is the buzzer from the pixhawk. These are important questions to this issue. 

    • "what firmware version are you running ? How cold is outside and how far is the buzzer from the pixhawk. These are important questions to this issue."

      I'd have to check to confirm.....but 3.3.3 sounds right. (If you want a definitive answer on this one, let me know) 

      My buzzer location.  Hmm.  Hadn't really thought of that.  It's 5 inches from the center of Pixhawk and 11 inches from GPS/compass puck. 

      Not sure if the temperature is an issue since I'm indoors for all the "configuring".  I do believe strongly in placing the rotorcraft outside, without the battery, to acclimate to ambient temperature and keep the battery warm, indoors, until I'm ready to boot everything up.  It can get pretty cold in Rochester, NY.

    • Hi

      I also had the inconsistent compass warning during setup. You did not indicate if you are using an external GPS and compass, If you are it may indicate the internal Pixhawk compass and the external compass don,t agree. After much time trying to solve my compass issue I simply disabled the internal Pixhawk compass in Mission planner. Had not problems after this. In any case the external compass performs much better.

      The craft and Theory option works great. You would be aware that you need to down load a special version of pixhawk software until the next version of pixhawk release catches up, also Opentx version 2.1.7 has some issue which will be fixed in 2.1.8

      Cheers Henny

    • @ MArtin your problem sounds like temp related since you leave the pixhawk outside before you fly it can affect the IMU to the point where it wont arm. Try to short the connector, or try to arm indoors with pixhawk being indoors for more than 10 min to warm up. If that works then bleeding the circuit by shorting will always work. That has been my workaround. To completely fix this issue see this post.


      You guys need to research more. 

    • temp is a huge factor with the LSM IMU. 

      Also how good are your offset values after compass calibration ? 

      Try to arm indoor. Also shorting the connector that plugs to the battery has always worked for me but that is just a work around. 

      There could be different factors causing this issue you guys need to work on isolating this. Whether its a HW issue with specific sensor or even a solder issue. {(which was not my case, but some guys have reported that it was a know issue on a batch of pixhawks)

    • FW APM:Copter V3.3.3 (31b4e166)

      The buzzer is mounted underneath the upper part of the central chassis, about 14 cm. (5.5 inches) from the center of the Pixhawk.

    • Thats enough distance.

      Two things i would try ALL you guys here who have this issue.

      1. Turn off one of the IMUs and use one then see if the issue persists with 1 IMU or with 2 only. Also that way you eliminate which IMU is causing this.

      2. Short the connector that plugs into the battery (Obviously with battery not connected !) for 10 sec. See if that resolves the issue so you can arm.  

      Also you can try to fly with one IMU disabled and examine logs for performance difference. 

      If you skip arming checks with this error and you fly in stabilize in a safe environment i would compare the logs between IMUs. Any variance. 

    • I'm looking for the IMU parameters, but I cannot find it. How is it listed under the "Advanced Parameters List" on APM Planner for Mac?

      I also looked for it under the graph tab, but I just found the RAW_IMU and SCALED_IMU2


    • Its this : 

      INS_USE: 0 or 1 

      INS_USE2 : 0 or 1

      3rd IMU does not exist on pixhawk as you probably know 

This reply was deleted.