Trying to get Pixhawk working.

I had a hexcopter with a pixhawk over a year ago. I was using a Taranis X9D back then. I was able to build it, set it up, and get it working back then. Then I had to stop using it for quite a while and now I am trying to get back at it and I am having no luck getting a new system working. I was going to use a pixhawk 2.1 in a fixed wing with either my Taranis or a Horus X10S. But Iwas unable to make the 2.1 work with the Taranis so I thought I would go back to a pixhawk. But I can't even make it work. It is as though I have gone brain dead.

I know this is not much to go on. What is your best advice on starting (restarting) with Pixhawk? As I said I am heading to a fixed wing with Pixhawk 2.1 and a Horus. I feel like an idiot but would really appreciate some help getting going again.

I am able to bind Horus to X8R (or X4RSB) and verify that the servos work. But I can't get pixhawk working with it. My Horus firmware is 2.2.2 and I have Installed OpenTX version 2.2.2 also.

Thanks for at least reading this.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks again. When I get to radio calibration I get nothing. sometimes it is all black. several times i get the green areas where it starts but no response to stick movement. No little red lines. Large frustration. Something you said made me decide to try my Taranis. Not the plus but has always worked. So unhook Horus and try Taranis X9 first with Pixhawk and maybe with Pixhawk 2.1.

    So Taranis with PH. Radio X8R binds and output directly to servos works ch 1-4, maybe more, but seems fine. Power PH  and no servo response. Verify external power thru BEC so sufficient power to rails for servos. Arm PH. Still no servo movement. .X8R is connected to PH thru RCIN. Polarity is Signal on bottom. Connection to X8R is RSSI and nothing. SBUS - nothing   So skip most of this.

    Using PixHawk, Taranis, X8R I can now calibrate radio in Mission Planner but next step is Servo Output. Seems OK in Mission Planner but no servo movement. Servo plugged into pixhawk and Power supplied for servos thru BEC, not just USB. But no servo movement. I am missing something simple I know it.

    I am going to try same setup but with Horus. 

    Thanks again for any suggestions. Your last one helped by trying Taranis. 

  • Your end points should be the fixed on the angle of the ailerons suggested by the plane manufacturer. I'm not sure about the Horus. I use Taranis Plus with Craft and Theory scripts. I am not sure that you will get full green until you are outside and ready to arm and fly. Your mode channels should be on CH 8 and your AUTO TUNE on a 2-way switch for CH 7. 

  • thanks for the reply.

    I have watched all 9 of these at least twice and the 5 for pixhawk more times than that. But because of your suggestion I got the Cube (pixhawk 2.1) out and followed the videos exactly. My 2.1 connects to Mission Planner and all seems OK. I go thru the calibration.  He doesn't talk about or show radio endpoint setting. He has not connected the GPS yet either) But my big problem is that after the LEDs and beeps are done I do not get the green heartbeat. I rebound my X8R receiver with 2 jumpers attached. It doesn't work. So I tried mode 5 without any jumpers It binds and I can move a servo connected to the radio but not one connected to the cube. Also I do not have the green pulsations he comments on and you can see in the 2nd video. (see 15:54 cube connected only to Mission Planner by USB and green pulse is seen.) What am I missing? How can I be this dumb?

    I am going to start again and maybe watch the 5 pixhawk videos again. 



  • Try this series:

    Painless 360 Pixhawk 2

    He ultimately puts this version on a Talon fixed wing.

This reply was deleted.