Solo success with Nexus 5X (Marshmallow)

The Nexus 5X showed up yesterday, and, of course, had to try it with the Solo. The app connects fine to the sololink wifi and seems to communicate just fine with Solo (get the "Ready for takeoff" voice message once GPS satellites are sufficient). However, no GoPro video and under "System Info" in settings, I don't see version numbers for Solo, Autopilot, or Gimbal.

So, I can fly Solo, but no video in Nexus 5X/Marshmallow.

Anyone else had success? Or, find a workaround?


P.S. Went through the whole shutdown/restart/reconnect process with the GoPro to make sure it wasn't just a connection issue.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Eric, i have the old nexus 5, running marshmallow. When you first connect to the Solo wifi network, a popup appears saying "no internet access on this network, click here for options". Click that and choose "always stay connected to this network anyway". Doing that solved my connection issues with android and the solo.

    • Joe,

      Thanks so much! I'd ignored that new notification previously. Tested your suggestion last night, and...voila!...the GoPro video worked. Back in the air with the new phone.


This reply was deleted.