Using Tower App with Solo - how to

Has anyone tried using the Tower App with their Solo?

If so, how did you get it working (how did you connect to the Solo)?


Per Brad's comment below.  Here are the steps.

  1. Connect your Android device to the Solo wifi network.
    (you won't be needing the MavLink cable that Iris owners use).

  2. Launch the Tower App and select connection type *UDP* in settings.

  3. Click "Connect" on Tower app's main screen.

Careful: Crashes while using Tower are not covered by 3DR. Use at your own risk.  See post below for more info.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi don't know if this is the correct thread to bring up my problem ? But does any one else have problems with both the Solo app crashing and Tower app on a Android 5.0 pad ??

    • Found the problem the app PicoTTS seems to cause the crashes in both apps!
  • So I got Tower connected, and made a simple spline waypoint (squiggly line) mission all at defaults (66 ft high).  It asked if I wanted to add a takeoff and landing to it and I did.  I downloaded the mission, armed the Solo and started the mission.

    The Solo started bouncing up and down on the pavement and eventually flipped.  It kept running shredding the props, and I couldn't seem to stop it.  I tried the controller, Tower app, and also the Solo app..  I eventually picked it up (upside down) and held it while I was trying to get it to stop with the other hand.  Good thing, as it had worn the props down and was about to work on the spindles.  Eventually it did stop (after several minutes) but I am still not sure if it just got done or it was something I did.  I thought I was going to have to hold it until the battery ran out...

    So....Obviously I am missing "something" about how Tower works.  At this point I am pretty scared to use it.   Any suggestions on a tutorial on the details?  I am fine with the connections etc. as well as with the Solo and the Solo app.  Just need help understanding what I am missing about creating a mission, and why the Solo did what it did...

    Any help is much appreciated

    • 3D Robotics

      Are you sure you uploaded the mission from Tower before you pressed arm and auto. You need to "upload" not "download"!

    • Yes... wrong words, right action.   The nice lady in the  Tower app said the waypoints were recieved by Solo :)  

  • Is there a Tower manual so to speak? I haven't figured out how to use the select all feature to change all the wpt's altitude instead of  having to do each one. Or,,, how to set the default altitude. Great app! Seems more solid than the DP I've used in the past. Very slick. 

    • "Is there a Tower manual so to speak?"

      A lot of info and links here:
    • Thanks!

    • While in editor mode there is a square dotted box on the left. That is select all then look to right and you will see another dotted box that slides out profile for waypoints. If you do not see it let me know and i will try to post pics.


    • Thanks Martin  I do see that but with all the wpt's selected that slide out on the right says no available options??? If only one wpt is selected then I do the option to change altitude. 

      ps this is with a pixhawk not Solo

This reply was deleted.