First off, thanks for this great app. I have been using it with a naza controller for a while and it works great.

I recently tried to use it with an APM2.8 - firmware ArduCopter3.2.1 (latest stable). I am running the latest version UGCS (2.7.125-trusty) on ubuntu 14.04LTS. Telemetry is connected, I can send successfully commands such as "arm", but I cannot figure out how to upload a simple 4-waypoint route. I get the message "upload failed. Route not accepted."

The apm controler seems to be set up properly, I can upload a route from other gcs such as apmplanner2 or qgroundcontrol.

Attached is the log file (vsm-ardupilot.log).

I wanted to try alternative versions of UgCS to see if that fixes it but I cannot find links to previous versions for Ubuntu on the UgCS website - the repo only has the 2.7.125-trusty version available.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Until this day the wrong link, or the possibility to update his Linux computer to the current version, where not been solved. This makes not a good impression. Especially not even the version 2.8 should be downloaded to a computer with Linux.

  • Francois,

    Unfortunately 2.7 does not support ArduCopter 3.2.1. We fixed it in 2.8 which was not released on Linux. The upcoming 2.9 will include this fix, too.

    • Hi, thanks for the update. Looking forward to the 2.9! 

  • Hi Francois!

    Sorry for late answer. Can you please provide information about used vehicle profile in UgCS?
    Also as I can see Server component unexpectedly close connection when you try to upload your mission. Could you please send us all logs from /var/opt/ugcs to support@ugcs.com 

    Currently 2.7-125 is the latest available version for Linux. Meanwhile, at the end of May there will be next 2.9 release for Ubuntu LTS.

  • Hi,

    thank you for your feedback and logs. We'll take a look and try to figure out what is wrong.

    UgCS Team 

This reply was deleted.