I'm not sure if this is a setup issue or what but I'm about to pull my hair out.  I have a Samsung Galaxy Tab S2.  I have tried every which way I can think of to run the UGCS for DJI on my Android but I haven't been able to get anything but a white or black screen that gives the view from my x5 camera from the Matrice 600 Pro.  Just when I think I have the right set of steps figured out and the screen shows what the camera is seeing, it just stops showing the "live" feed.  This is the only app that I have found that will do what I am needing to do in the field and really like how it works, but am frustrated that I can't see what the camera is seeing.  Any help or thoughts would be much appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey Jason R.,

    Did you ever get this UgCS for DJI app to work?

    I have the exact same setup (M600, X5, Galaxy Tab S2 also with RTK) and my video is there sometimes but very unusable.

    Has DJI not released this SDK fix yet?

    I need to find a tablet that works.

    I can't use an Android phone because I have client's watching our operations and you simply can't see on a small screen.

    Can anyone suggest an Android tablet that I can buy?

  • Alex,

    That worked to solve the no image transmission signal in the DJI Go app.  Thanks!

    I still am not able to see any image when I am using the UgCS for DJI app.  As was stated above by Lillia, it appears to be in the DJI SDK.  It just makes it extremely difficult when I have to switch between the apps for simple things like getting my x5 in good focus prior to starting my missions.  For some reason I can't easily switch between apps without shutting something down or getting into the app settings and changing things around from default app.  I'm probably not doing something correct.

  • I had a similar problem with my A3 system and Lightbridge. The app said "No image transmission signal". I was initially told by DJI and every forum that it was a firmware issue. I needed to downgrade the firmware. Well I tried that. I tried every firmware combo possible, and still the same thing. Then I started messing with a setting called "bandwidth allocation" in the transmission menu of the app. It fixed the problem! Try that before messing with firmware. It could save you a lot of time!

    Jason Rourke said:

    Thanks for the responses.  Can anyone tell me what firmware version I could downgrade to that will at least let me view the feed?

  • Thanks for the responses.  Can anyone tell me what firmware version I could downgrade to that will at least let me view the feed?

  • Jason,

    There is an error in SDK of DJI. It appears on A3 autopilots (M600). After DJI fix it in DJI SDK we can start work on this issue in our app. Unfortunately, we don't have information about dates of DJI SDK releases.

    We sincerely apologize for any inconvenience.

  • I had the same issue appear just yesterday on my M600 using MapsMadeEasy Map Pilot with a thermal camera. I suspect the latest firmware update may be the culprit after testing everything that I could think of.

This reply was deleted.