• Hi There,

      I've got myself a problem/issue which I just can't fix or get it working.

      The drone is just not getting into Autotune mode, I've tried everything but It just refuses.

      I have done the same on different quads which is working fine, but on this one... poeh.

      I have a APM 2.5 Flightcontroller within a Discovery frame with a 30AMP ESC and 700KV motor setup.

      Today I did a full erase of the Eeprom and Factory reset and worked my way around through the entire wizard and put every in place.

      Started off with the default parameters where I found that it oscillates a bit so I tuned down the RateRoll P from 0,1500 to 0.1080 where it stopped and felt a lot better. It was actually flying not bad apart from a couple of twitches when doing some stronger Elevator or roll inputs.

      I went into the field and put the drone in ALT Hold mode, then switched to autotune mode but nothing happened.

      I've tried things over 2 months finding out what may be the case, but now I'm all of options.

      Which factors can disable going into autotune?

      If there is more information needed, please let me know, Il provide everything I can.

      Thank you so much.


      • I had this happen a few times and found out it was a silly thing. Over time my Turnigy Radio calibration for center changed ever so slightly so i never noticed it while flying. But the APM and Pixhawk did. So I re calibrated in Mission planner and there it was . Auto tune started and completed. So I would suggest to try re calibrate your radio in Mission Planner and go right into an auto tune.

        Just a suggestion from recent experience. 

        • Developer

          This is definitely one of the major reasons auto-tune doesn't start. Along the same lines. If you set the dead zone on the RC inputs too small you can also have trouble starting auto-tune.

      • Peter,

        See my post above in this thread, particularly the part about having to connect a wire from CH7 on the R/C receiver on the quad to the APM CH7 input.  You don't mention the RC controller you are using, but you also need to be sure the switch you are using is in fact radio CH7.  You may need to set that up in the controller.

        One way to check to be sure the switch is changing CH7 into the APM is to set it up on the bench with props off for safety.  Go to the radio calibration page in Mission Planner.  You should see the value for CH7 change when you flip the switch on the controller.

        • Hi Jim.

          Thank you for your quick reply...I'll add some more detail, I didn't want to over inform you with too much details haha.

          Oke here we go:

          4x TBS 30amp bulletproof esc's
          4x TBS 750kv brushless motors
          1x Top & Bottom Plate
          4x TBS black arms
          4x SET GRAUPNER E-PROP 9X5
          1x TBS core
          1x RF ThinShield
          1x TBS Flamewheel VTX mount
          1x RCTIMER APM 2.5 flightcomputer
          1x 3DR power module 
          1x RCTIMER datalink (transmitter & receiver 433mhz)
          1x 3DR gps module (nieuw)

          I have a Frsky Taranis TX (in which i'm very very proud of) with a ImmersionRC 433Mhz DJT module, The RX on the Discovery is an Immersion 8CH High diversity Receiver. Most important is probably that everything is connected by PPM muxed.

          With this setup, I configued all the 8 channels which are also working in the Mission planner:

          1. Throttle
          2. Elevator
          3. Aileron
          4. Rudder
          5. Gear switch -> 3 Flightmodes
          6. Tuning Knob
          7. Failsafe
          8. Autotune

          So, does the channel 7/8 need a pshyical Servolead because of the Autotune? I would be very suprised because the Channel is working properly in the missionplanner.

          Hope it helps, thanks a lot! :)


          • Peter,

            I'm not at all familiar with your equipment. As I suggested above the test to assure your radio CH8 is making it to the APM is to use the radio calibration mode of Mission Planner to see if CH8 changes when you flip the CH8 switch on your RC controller.  That will prove the change in PWM value the APM is looking for on CH8 is getting from the switch on the RC controller into the APM.

            If it is the next thing to check is if the amount of PWM change is enough to be recognized by the APM.  I believe Randy included in his video and writeup on Autotune some value ranges for 'on' and 'off'. 

            Probably the best way to do this is run through the radio calibration sequence in Mission Planner.

            Another thing to check is to assure you are not starting the flight with the CH8 switch already 'on'.  On my DX8 I found the '1' position on the switch corresponded to 'off' from the APM/Autotune point of view.  I had to start with that switch at '1', then flip it to '0' to enable Autotune

            • Hi Jim,

              I'm pretty sure that the PWM values are changing correctly, I've also ruled out that it could be a defect channel or something like that because when I assign a different function to the same channel + Switch it is working properly.

              I see that the switch in "OFF" mode has a value of 1xxx , in "ON" it has a value of 19xx.

              I could try just to be absolutely sure to start in ON mode and see if this works, I did not have time to check this or upload the logs.

          • Same problem here, Peter and I've posted in several places and no one seems to have a clue. I'm also having a problem being able to engage hybrid (poshold) mode in 3.2. Not sure if its related but its sure strange these are the only 2 problems I'm having now. I'm also using a Taranis and can verify autotune is engaging via telemetry and mission planner however nothing happens. My money would be on the APM not sensing the sticks are centered but I've verified PWM trim for channel 1 and 2 and my logs indicate the same value when my sticks are centered. I'm at a loss. 

          • Developer

            Hi Peter,

            If it doesn't work this time post a log file.

            Good luck!

            • Hi Leonardthall,

              To which level logs am I looking? Is the standard/default logging enough or do I need to enable deeper logging?

              Thanks so far! :)

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21