Replies

                  • I can fix all your problems!  Do as I did toss the thing in the garbage lol.  Spend the 400$ on a full wookong system and never worry about this crap again lol

                    Honestly I have 4 apm units. 3 DJi units.  I so far have had every problem you can think of with my 4 apm units since 3.x.  My pixhawk-y6, apm 2.6-oct, Apm 2.5-plane, and dji flame wheel with 2.6 apm.   Not one of them will auto tune correctly to the point they fly even close to my dji units.  I know it's an open source project,  But there getting to the point now with failures now where I moved my camera setups to my Dji units now off the apm ones out of fear of losing everything. If auto tune worked there would not be 7801 people posting there having problems in just this section?

                • I take it back. I *did* do the radio calibration step.  So maybe I should calibrate the transmitter instead?  It seems to be a crappy quality transmitter - turnigy 9x - $40 included transmitter and 8ch receiver.  The yaw joystick needs constant fixing (occasionally I need to adjust some offsets inside the thing to keep the yaw around 1460-1500 centered) and each time I turn on the receiver I never know what I'm going to get.  That's probably it - 80% of the time the yaw doesn't change but occasionally it does.  Often it's bad enough that I can't even arm.  There must be loose wire inside the roll potentiometer or something.

                  • So I got it figured out.  The main thing seems to be that when my controls on my transmitter are completely centered they tend to put out a signal of around 1466 instead of 1499.  So I had to trim it all to be happy for the apm software.  I wish the radio calibration would use the values of the controller.  Anyway I got autotune to work, thanks guys.  And I learned a few other things (like my compass was off by 20 degrees).

                  • George, 

                    To echo Randy's point, the RCx_TRIM is important in this case as it tells the copter when you're not requesting any angle demands of the copter, and the copter won't engage AutoTune if it thinks you're trying to re-position (a lean demand of .5 degrees is still a lean demand)

                    To further investigate the problem, I suggest the following:

                    • using the radio calibration screen (but not pushing the Calibrate button) observe the PWM values reported by your GCS.  I haven't looked at your logs, but based on the comments from Randy and Leonard, they are likely not sitting at 1500 exactly.  It is a good idea to make sure  your trims are centered in your radio at this time, as well.  Record the values for Roll, Pitch, and Yaw.  Hopefully they are not bouncing too much.  Document how much they swing from what appears to be the "true center."
                    • In Full Param list, compare the values you recorded from the previous step to the values in RCx_TRIM.  Make any adjustments necessary
                    • Also in Full Param List, compare your "swing" that you documented to corresponding RCx_DZ params.  If your "swing" is more than 30microseconds, you'll want to adjust the appropriate values.
                    • Hover your vehicle in AltHold and verify your throttle is at 50% give or take.  if it isn't, check the wiki for the instructions on setting that correctly.

                    The main goal of the exercise is to make sure the autopilot is not perceiving any "pilot demands" to roll, pitch, yaw, or altitude.  If it is, it places the AutoTune mechanism on hold because it believes you are trying to reposition the vehicle.  It doesn't know that what it is seeing is unintentional, it just knows the radio is saying "wait, hold on.. need to do something first."

                    With your Intertial Nav variance, the first thing that comes to mind there is making sure that when you power the vehicle up, it is perfectly still for the first few moments until the flashing lights stabalize.  If the vehicle is moving while the LED is rapidly flashing red/blue, the gyro start-up is goofed which is one of the ways to trigger that log event (unless I am mistaken - Randy nor Leonard like bad info getting out so if they disagree with this I'm certain they'll correct me.)

                    Good luck

    • George, 

      Sorry you're having troubles.  Next best thing to do is try a fresh radio calibration.. you want to make sure that not only the min/max PWM values are all spot on, but so is the mid_rc.    After that, you want to make sure your copter is hovering at 50% throttle while in AltHold.  FYI the logs won't show it go in to AutoTune mode, so don't sweat that.  Also, that level of noise is perfectly acceptable, and I don't think noise would stop the autotune, but depending on how bad it is could potentially cause other issues that end up to AutoTune stopping prematurely. 

      If radio calibration doesn't work and verifying mid-throttle for AltHold hover doesn't work, attach a log and someone can have a look.  Also, any chance you can upgrade your firmware to 3.2?


      Best of luck!

      • I read about random APM related stuff for hours last night and I'm thinking I might have accidentally been putting the copter in "auto trim" mode when I was just trying to arm it.  It looks like 2 days of rain here so I'll install 3.2 and I'll play with Arm and disarm indoors and recalibrate the radio (for the 10th time - it only takes a few seconds).

        I have ch7 on a knob, not a switch.  That doesn't matter, right?  It still goes to about 1850 when I turn it all the way.  Will report back after the weather dries out a bit.

        My arm procedure doesn't seem quite right.  I wait for blue steady (gps lock) then I do the throttle down and right (yaw right - mode 2) and red keeps flashing and I hold it until blue starts flashing also (I now think that's autotrim - at 15 second point).  I thought it meant "i don't want to arm" so then I go down left (yaw left) an then right again and it goes red/blue both solid.  I'll experiment with arming some more today.  I'll try 6 seconds only.

        • Hey George,

          ch7 on a knob is fine.  Also, yes, you're arming in to AutoTrim mode.  You should only need to yaw right about ~4 seconds.  You will see a Gyro Cal light pattern emit in 3.2 where the arming light flashes quickly a few times between red and blue, and after that stops, you're armed.  

          6 Seconds is more than enough, 10 second is when the AutoTrim mode is activated.

        • Moderator

          Be careful playing with arming modes with props on

          • :)  Yeah I know.  I always make sure the props are clear and that the USB cable won't get close to the props but I was planning to do this without the battery anyway.  I've been flying/tinkering with this home built for several weeks now so I've made most of the mistakes by now.  :)

            By the way it's my own design and 3D printed.  I've had to change the design to stiffen it quite a bit as even though it was plenty strong, it wasn't plenty stiff - especially at the "wrists" near the props.

  • FWIW I did an auto tune on my x8 I got the following

    SP Gain 10.500

    RP Gain .0.2305     I .1225      D   .9192      Yaw 4.500

    Seems to fly quite well on this. 

This reply was deleted.

Activity

gotham liked gotham's profile
yesterday
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…