Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey guys,

    I don't know how big of an issue this is, but I wanted to report back that I figured out how to "unbrick" these minimosds when you get stuck with the failed to talk to bootloader issue.  I haven't nailed down the exact root cause, but I did narrow it down to an initial firmware load coupled with an "Eeprom mapping out of date" operation.

    My understanding of the config tool is that it checks for a revision signature, and if the revision signature don't match - it fires off an eeprom mapping rewrite to ensure that no character data gets truncated or otherwise mismatched.  The problem here is that when someone with osd config tool x upgrades to osd config tool x.1 and runs into that eeprom mapping rewrite.

    9 times out of 10 - the eeprom mapping will simply just work, but I've seen a lot of issues being reported lately where the firmware update process overwrites the bootloader which kills its ability to connect over an FTDI connection.

    The fix involves a few extra tools and I'll do a proper write up when I'm done shooting the video for this.  You'll be amused to hear that in order to figure this out - I removed the atmel chip from the board, and recreated portions of the circuit on a breakout board - learned a lot in the process about bootloaders :)

    In short it goes something like this:

    * firmware updated followed by an eeprom remap bricks the board resulting in a "failed to talk to bootloader" message

    * you need to reflash a new bootloader to the board through the AVR/ISP header pins ( the 6 holes in 2 rows to the right of the atmega processor).  For reference, the reset pin is on the top left, power pin on the bottom there's no question on orientation - atmel processor is to the left, max chip to the right.

    * You need to solder in 6 straight through hole header pins into the socket.

    * You'll need a USBASP programmer (like $5) with a 6 pin ICSP header.  Use a multimeter to trace out which is the power pin then connect them with the proper orientation

    * Next - fire up Arduino SDK

    * Under Tools -> Board - choose Atmega Pro Mini 5v 16mhz 328p - as a side note - if you look up boards.txt you will see this entry shows the famous "fuse bits" that are associated with the minimosd - FF DA 05 - the important bit is "FF" which means external clock greater than 8mhz (which is correct since there is a 16mhz resonator on the board attached to pins XTAL1 and XTAL2)

    * Under Tools -> Programmer - choose USBASP.  If you don't have USBASP available as an option - you can simply add it to the programmers.txt config file located in your Arduino folder - I'll let you google how to do that.

    * Assuming your USBASP is functional and loaded its own drivers properly, you can now burn a new bootloader.  In the Arduino SDK - Under Tools -> select Burn Bootloader

    This process takes about 30-40 seconds so don't freak out when it looks like the SDK is doing nothing.   If you get some error messages about usbasp not being able to sck - ignore it, or update your usbasp firmware - either way it's not relevant.

    You may have to do another eeprom remapping, but since the firmware's already loaded, and now having the bootloader burned back on, you shouldn't have any issue connecting with it.  I confirmed I was able to read and write to the chip.  I couldn't do a character update for obvious reasons, but that should just work.

    If you stay within your release/config tool version - generally speaking you won't run into problems.  You start running into issues when a characterset or firmware version from one config tool meets a different signature from a different configuration tool release.

    In the attached photo - I recreated the left half of the circuit board using .1uf capacitors, 10k resistors, and a 16mhz crystal paired with 22pf capacitors to ground...that's obviously not necessary, but with all the wiring and rewiring I had to do while investigating this, it was helpful to have the chip separate from the board.

    Iskess from rcgroups - donated this board for the experiment and thanks to him, we have an answer to this buggy little issue.


  • Interesting video about quadrocopters for inspiration.

  • A little fpv with the latest fw and rssi finally set up :) I'm using link quality output on the ezuhf rx.

  • Got it on the OSD! Now I can go further safer :-) Thanks everyone and to summarize in case anyone else has this setup.

    1) connect molex plug from D/A converter into molex connector on ezuhf.

    2) Make servo cable using red, black and yellow (if you want to use link quality) or orange if you want rssi. I prefer LQ.

    3) Plug that into A0 or A1 or other available port and set same port in standard parameters in MP. I set mine to A1.

    4) Connect to minimosd via ftdi and change rssi to RAW

    5) View OSD video to check what max and min register when radio is turned off and on.

    6) Connect again to OSD via FTDI and uncheck RAW and enter the min and max viewed from step 5.

    Most of this is outlined here but it needs a little updating.

  • OK almost got it working. Have it hooked up to the 5v on my APM at A1 and when I check the signal quality link cable I get 0-4.5v and on RSSI I get 0-3.6V. I prefer the quality link so set up a servo connection for that and hooked it to the APM A1. Connected to Mission Planner and set rssi to A1 but it's just reading 0 for rssi and remrssi. So I know the converter is working but I need to see why APM is not seeing the signal.

    Shouldn't I be seeing something on rssi or do I need to enable something else? I also tried A0 but same result.

  • I finally got my PPM to Analog Converters from Mictronics and wondering if anyone here has already set one of these up? The connection to ezUHF is simple enough via molex and doesn't occupy one of the 8 channels but I'm not sure about the connection to the APM2.5. Not finding much info on the old wiki or new doc site about rssi. In MP it shows I can set it to A0, A1, A2 or A13.

    On the Mictronics converter it shows RSSI output on orange and supply voltage 5V and ground. I've set it in MP to A0 so do I just connect red to center pin on A0 and black on A0 edge of board and orange on A0 inside pin. I don't want to smoke my apm so if someone knows how to hook this up let me know.

  • Will this work with clones like: MAVLink-OSD?

  • One year, Almost 60.000 views and 184 pages of comments. That's quite a bit.

    Hate to barge in on an important discussions but may I suggest to the devteam that they start a fresh thread with a short introductory overview of the development and current situation?



    (who is about to set up his first MinimOSD)

  • 100KM

    Can I use "CT Tool for MinimOSD Extra Pre Release" to load "MinimOSD-Extra_Plane_Pre-release_r615.hex"?

  • Thanks for the great work on this OSD!  Here is my test flight of r609 and the clock works as promised :)

    I got many more satellites locked this time as well.


This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022