Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Hi,  Gábor!

        Today was great weather and I tested copter with new firmware to no avail. Never get zero problem again, but look at the clock :)

        https://www.youtube.com/watch?v=cTwAnRA6CkA

        • Hi Gabor and Vilnis,

          I also had the altitude reset during flight issue. Since I put the release 750 I have not seen the problem appears. Still have to perform more test because it seems to be very random.

          However, as the last video of Vilnis, the flight time clock is no longer trigger ... stuck between 0.00 and 0.01.

          Thanks guys

  • The MINIMOSD 2.3. pre-release:596 overlay stops after a few minutes into a flight.  Recent change was an upgrade to apm 3.1.  I've embedded  a video showing the failing overlay.  Option to switch between multi-screens is disabled.   Issue only happens when in the air and affects two separate boards from different suppliers.  I didn't see this issue with APM 2.9.1.

     

    Any ideas how to fix this?

    • you are reporting the exact same problem I have/had.

      It started when OSD suddenly diapered without notice, and lately I am having the same problem where OSD blinks but keeps working. After months of tests I found out that the problem is somehow related to noise on the power/signal bus which in my case looks to be generated by the servos (plane). I have replaced my UBEC and rewired power to APM in such a way that power is now fed to both IN and OUT sides of the APM (Jumper in place) and I got some stability but your problem looks to be related to noise as well on power lines and I don't know how to get read of it for good.

      minimosd is VERY sensitive to power issues.

      Hope this helps. 

  • Here's an interesting one...

    All of a sudden my MinimOSD is consistently displaying incorrect temperatures ranging from 537 deg F to 654 deg F.

    But when I connect my APM via 3DR Radio to Mission Planner to view APM telemetry it shows correct temps in the 70-90 deg F range.

    Why would MinimOSD show temps incorrectly, even though the APM is apparently sending correct raw data to the MinimOSD?

    What changed?  I did upgrade from 2.74b to 2.78b just before this started and I also made some very minor mods to block light from my barometric pressure sensor (which I've since removed) and replaced the 3DR power module to APM 2.5 cable that was wearing out.  I've tried rolling back to 2.75beta2 but that didn't fix it.  I'm having problems getting all the way back to 2.74b and I haven't figured that out yet.

    -----------------

    More details if interested....

    -----------------

    3701690322?profile=originalI've done a fair bit of debugging to find the root cause without success.

    MinimOSD never displays a number higher than 654 deg F, but when the temp goes higher it rolls to 0 deg F and continues to climb from there.  For example, 655 shows as 0, 660 shows as 5 , etc.

    When I put my finger on the sensor, the temp rises and it goes back down when I remove my finger.  In other words, the sensor is working.

    When go into terminal on Mission Planner, and run an airpressure test, I see expected results:

       Alt: 0.00m, Raw: 101617.9 Temperature 30.6 (i.e. 87 deg F)

    This implies that the sensor is working perfectly yet why whould MinimOSD display incorrectly?

    I've tried two different MinimOSD devices with same results. I've tried different versions of APM firmware and different versions of MinimOSD firmware.

    I'm fairly stumped here. I've not seen any other posts related to incorrect temps so I'm not at all confident going back to 2.74b will fix anything.

    As far as I can tell, this doesn't affect anything else and my plane is flying fine - just an annoyance and curious why something isn't working like before.

    • I installed various firmware to my 3DR APM 2.5 and 3DR MinimOSD using Mission Planner 1.1.5187.14200 and I see that this appears to be a bug introduced somewhere after 2.74.

      APM     MinimOSD-Extra               Results

      2.74            2.4_r676               Displays Temps Correctly

      2.76                2.2                    Displays Temps Wrong 

      2.78b              2.2                    Displays Temps Wrong

      2.74                2.2                    Displays Temps Correctly

       

      I'm trying to identify the exact Git commit that caused this but I'm having problems compiling anything before Sept 21, 2013, commit bcce2e4fc5a0b27a0b727256a243d721873cf3aa, due to this error:

      avr-gcc: error: unrecognized command line option '-assembler-with-cpp'The problem is introduced sometime before that commit.

      I presume that most people don't have temperature on their panel since it is off by default, which perhaps explains why I've not found anyone else complaining about it.

  • With camera on

    http://youtu.be/6Nvk6YYVAfw

    With camera off

    http://youtu.be/HUwaXlKuge0

    There are horizontal white color bands, does anyone know the reason? Thx

    I have my radio off and I did move the wires around, no luck.

    And is it normal that the rectangular chip in the middle get hot? 

    • And the rectangular chip in the middle is hot. Is it normal?

      I have checked the 5V and 12V pinout, they are ok. Thx

      Then, I found this link.

      http://flitetest.com/articles/minimosd-heat-mod

      I didn't put any heat sink and ran it for 30 mins. Suddenly, the current went up to 5A as I remembered on the OSD!

      Scare of using this board now. Getting a new one.

    • Try turning the dim setting in OSD config tool down.

      • OSD brightness is low already.

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…