All motors stop suddenly with Pixhawk

I was maidening a mini H-quad with a Pixhawk running AC3.1.  On my first hover in stabilize mode, it worked beautifully. It was hovering perfectly still without any trimming needed. About 4 minutes into the hover, with the quad at about 2 meters high, all the motors suddenly cut off, and the quad just fell to the ground. I have attached the Pixhawk log file and hope some knowledgeable kind soul can help me decipher what went wrong.

Thanks for any help rendered!

Staq

PS: The quad suffered no damage, only 2 broken props. Really wish to know what really happened up there. Dare not fly it at the moment.

2014-08-22 23-25-45.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,

    Any solution on this topic? What was your final solution Staq?

    Just asking because testing my first Y6B, and same issue with stopping motors.

    • you need to post dataflashlog - until then, I doubt it's related :)

      • Can help me somebody to find out what the problem could be?

        Analyzing logs too big task for me, as a Pixhawk beginner..

        http://www.filedropper.com/10_8

        • This is correct.If on your desk you arm and try to pitch or roll,,the copter MUST pitch or roll proportionately. If the copters lean angle DOES not match your stick movement within a couple degrees, it will result in CRASH DISARM,and all will stop. You can test this theory by not using battery power,but just usb. Then arm, then when you -pitch,or roll--move your copter in the same direction you move you stick at the same rate, and you will find your issue will not happen. It was built in like that!!!!  Trust me, it will not do that in the air! I had to ask Randy on this who gave the explanation. Hope this helps

          • Hi,

            Just a follow up. It seems that one ESC was unhealthy during the motor tests, and that caused the sudden death(disarm+ceash).

            Few days later my props arrived, installed them, wanted to test again the motors one by one, and one motor wasn't spinning up, just moved few millimeters back and forward.

            This was the moment when I suspected one ESC failed.

            Had to change to a new one, and everything worked fine.
            Will have test flights tomorrow.

            But for sure, need to change for a quality ESC soon, for Hobbywing XROTOR or KDEdirect...

        • the attached log contains no flight,

          the airframe is mostly level within few degrees, your input asks for more, on final "crash detect" the airframe was level within 1degree, (on ground) , your input requested ~27 roll to the left.

          then another Error 12.1  Crash detected, which stops your motors.

          It seems you need to do a decisive takeoff,  I guess you are so close  to ground, the airframe cannot achieve some of your requested angles, and detects a crash.. (being unable to reach desired attitude)

          fly in the air, not on ground :) 

          • Hi Andre,

            You're right. It wasn't a real flight, but a test run on my desk.
            Is that normal, that on a test run, without props, the motors cutoff sometime?

            Is it safe to make a test flight in this state of readyness of my drone?

            Or chance that will motor cutoff in real flight too?

            G.

            • no, motors do not stop during flight, unless people have an brownout (power loss to the AP)

              there is also a chance of something called sync problems, - some motor and porpeller/esc combination may have trouble keeping in sync during big throttle transitions.  - but that's one, not all motors at a time.

              what you saw is normal - motors will stop if armed, og ground, idle and no input, or if a crash is detected (you basically simulated one by preventing the airframe from achieving commanded/desired attitude)

              whatever it is ready or not - will mostly depend on how well PID's match that frame, there is only one "normal" way to find out (take off) or many ways that include suspending the airframe, holding it (may be dangerous) and so on..

              If you are using the 3DR Y6B (not sure if Y6B can be something else.) , then you should be fine with stock PID's - and can forget the sync problems I mentioned too.

              unless you know what you do, understand the basics in it, try to see if there is a experienced person nearby that can help you.

              finally:

              you started correct - in stabilize mode  - this is the first thing you should have working, and be able to fly -then you can do an autotune

              then you can try things that depend on magnetometer+gps.

              • After browsing many forums and posts, it seems to be a ESC compatibility issue.

                Looks like I've to ditch the DYS blheli ESC, and change HobbyWing Xrotor series.

                This Xrotor will run without issues together with Pixhawk.

  • Andre, what if the power module is faulty? Somehow it prevented enough power from reaching the ESC but just enough for the Pixhawk to record it's final death plunge. Just a speculating.
This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…