• some with an idea of what could cause this behavior ?, thanks

            • ok, it works on the Taranis, it is just the simulator what is not working right.

              next step , configure teensy ...

  • also , on the simulator , i have 13 pages , and on the terrines , 12 , the one missing on the Taranis  is "special functions", could that be related to not executing properly the LUA script ?

    • Make sure you have lua enabled when you upload the firmware with the companion.

  • i can't make the LUA script to appear on my teranis, it just shows a screen with a screen just showing the name of my model and battery voltage .

    in configuration , i can't select a script for screen1 , in fact it shows the custom screen script choice , empty.

    and the script is properly located on the model folder , with the same folder name as the model .

    using opentx2.1, any advice , VERY appreciated ? , im using the lua script in this page :


    This MavLink_FrSkySPort repository is discontinued! The development is moved to Clooney82/MavLink_FrSkySPort where we work together on this. Please d…
    • As far as i know this LUA script do not work for opentx2.1 yet. Hopefully someone updates it soon becuase im in the same situation as you.

      If you create a directory called telemetry (not in the modelname directory but beside it) and place the script there you will find it in the setting for screens. This is a new feature for 2.1 and the old telem1.lua no longer work. The script till still not work but this is how you have to place it once it does.

      Hope it will help you, it took me a long time to figure this out myself.

  • Hi Rob, could you please tell me which one is the latest lua script version, for 2.1 openTx firmware ? thank you

  • Hi there,

    Could somebody tell me, how could it be ?!
    Why script shows the wrong watts ?

    In offset.lua I specified 148W 


    • hi, need more infos.

      which apm/pixhawk telemetrie settings/values do you use, also which ardupilot version and which opentx version.

      which current and voltage sensor did you use and also your offset settings for "O-SET mAh%" and "O-SET Wh%".

      at least is this the original lua telm1.lua from wolkstein branch? else i can not say what goes wrong.



      • Hi Wolke,

        re-uploaded teensy and telm1.lua from your branch. Got same result. Script working at all but loose somewhere 100Wh. I got 48Wh from 4S 10A battery instead of 148Wh...

        mAh was calculated correctly just wrong numbers for Wh.

        Could you advice me something what can I check else to get correct Wh measurements ?


This reply was deleted.