• Hi,

    I tried the 2.1 version, but I get readings now and then. Some of the values like RSSI, SWR, RxBt and Cels (I use FLVSS) update often but the others comes and goes as they like, sometimes it can take 30-60 seconds Before a sensor updates?

    Could it be that I need to update fw on the X8R or is it something else?


    • Did some debugging and it was the LED routine who took too long time so it messed it up, changed the loop() so it only runs LED_process every 0,5 s, and then everything worked fine.


  • I'm using Clooney82's mavlink for  teensy with OpenTx2.1. I tried to config GPS telemetry data for OpenTx 2.1. But, the gps data that Clooney82 provides Model000-2015-09-09.bin is working. But I can't set GPS telemetry data for my own model. The Model000-2015-09-09.bin's GPS custom field is very long wide, but I can't config like that Clooney82 provides. I attached the image file that I captured. Please let me know to to set GPS telemetry data like Clooney82's



    • That image of Clooney82 is due to a bug in OpwnTX Companion which formats some of the lines incorrectly. What you see on your own Companion screenshot is in fact a correctly formatted sensor line.
      • The Clooney82's template provides "0 ° 00' - 0 ° 00' " unit and my template format only provides "0 °". So I can read GPS long integer data (ex:2883123333) at Telemetry screen.But, the Clooney82's template provides correct GPS format data such as "166 ° 77' 66.01E 37 ° 22' 22.18E" .

        So I'd like to know  GPS "0 ° 00' - 0 ° 00' " unit at OpenTX 2.1 telemetry screen. But, I can't configure like that.

  • Hi, thanks for your work, I just tried to download to the teensy, when compiling it always say 

    'mavlink_msg_global_position_int_cov_get_time_utc' was not declared in this scope

    the GCS_Mavlink library is added in the Arduino

    what can I do

  • hi, im having trouble with verify. its giving me an error. I am using 1.6.5 arduino, 3.1 teensy, configuring for an apm 2.6 with x8r reciever, using win 7. Any advice would be greatly appreciated! 3702117547?profile=original

    • Have you unzipped the libraries into your Arduino library folder correctly? You should have the folder GCS_Mavlink in your libraries folder which contains the the GCS_MAVLink.h / .cpp files and the include folder which drills down to the file your error is pointing at. Check the folder structure of where the GCS_Mavlink.h file is in my screenshot below.

      It looks like you have copied the GCS_Mavlink.h file to your sketch folder? It should not be here, only in the the library folder.

      GCS_MAVLink library structure.png

  • Im facing a problem on properly adjusting the dividers for the individual cell volts meter.
    Even I calculate them properly , it doesn't seam to make the adjustment and I have two of the five cells that indicates very wrong values.

    Will appreciate some guidance on what should I try first in order to find what is wrong .

    Thank you
  • it seems that I really need to buy teensy 3.1 now :) my 2.0 is not supported anymore

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25