Replies

  • I'm using Clooney82's mavlink for  teensy with OpenTx2.1. I tried to config GPS telemetry data for OpenTx 2.1. But, the gps data that Clooney82 provides Model000-2015-09-09.bin is working. But I can't set GPS telemetry data for my own model. The Model000-2015-09-09.bin's GPS custom field is very long wide, but I can't config like that Clooney82 provides. I attached the image file that I captured. Please let me know to to set GPS telemetry data like Clooney82's

    Thanks.

    test.jpg

    • That image of Clooney82 is due to a bug in OpwnTX Companion which formats some of the lines incorrectly. What you see on your own Companion screenshot is in fact a correctly formatted sensor line.
      • The Clooney82's template provides "0 ° 00' - 0 ° 00' " unit and my template format only provides "0 °". So I can read GPS long integer data (ex:2883123333) at Telemetry screen.But, the Clooney82's template provides correct GPS format data such as "166 ° 77' 66.01E 37 ° 22' 22.18E" .

        So I'd like to know  GPS "0 ° 00' - 0 ° 00' " unit at OpenTX 2.1 telemetry screen. But, I can't configure like that.

  • Hi, thanks for your work, I just tried to download to the teensy, when compiling it always say 

    'mavlink_msg_global_position_int_cov_get_time_utc' was not declared in this scope

    the GCS_Mavlink library is added in the Arduino

    what can I do

  • hi, im having trouble with verify. its giving me an error. I am using 1.6.5 arduino, 3.1 teensy, configuring for an apm 2.6 with x8r reciever, using win 7. Any advice would be greatly appreciated! 3702117547?profile=original

    • Have you unzipped the libraries into your Arduino library folder correctly? You should have the folder GCS_Mavlink in your libraries folder which contains the the GCS_MAVLink.h / .cpp files and the include folder which drills down to the file your error is pointing at. Check the folder structure of where the GCS_Mavlink.h file is in my screenshot below.

      It looks like you have copied the GCS_Mavlink.h file to your sketch folder? It should not be here, only in the the library folder.

      GCS_MAVLink library structure.png

  • Im facing a problem on properly adjusting the dividers for the individual cell volts meter.
    Even I calculate them properly , it doesn't seam to make the adjustment and I have two of the five cells that indicates very wrong values.

    Will appreciate some guidance on what should I try first in order to find what is wrong .

    Thank you
  • it seems that I really need to buy teensy 3.1 now :) my 2.0 is not supported anymore

    • Would there be no more support for teensy 2.0?
  • Hello! I have been using this feature for quite long time witrh Wolke code for Taranis 2.0.17. Now upgraded to 2.1.3. So I had to change everything on Taranis. Script are working for voltage, amps, heading, alt. This is what i get from Teensy with old Tennsy3.1 code from wolke. So I wanted to upgrade also my Teensy. 

    Everything is from Clooney82 github. https://github.com/Clooney82/MavLink_FrSkySPort/tree/s-c-l-v-rc-ope...

    I have Arduino 1.0.5; Arduino 1.0.5ERW; and latest 1.6.5. Libraries are copied, all three have Teensy boards to select. 

    The problem is that i cannot compile latest code. All three give me error messages. No errors with wolke code for Teensy3.1.

    I ve been reading latest posts, that people are happy with Clooney82 code. 

    What Arduino you are using? Or there are some hidden small tricks?

    Here are what i get from Arduino.

    Thanks!

    3702114460?profile=original

    Clooney82/MavLink_FrSkySPort
    This MavLink_FrSkySPort repository is discontinued! The development is moved to athertop/MavLink_FrSkySPort. Please do not use this repo, and follow…
This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
gotham liked gotham's profile
Dec 3, 2020
More…