• Hi

                The folder structure is the standard for OpenTX 2.x

                The sounds go to the SOUNDS\en folder

                and the BMP's go to SCRIPTS\BMP

                the script itself goes to SCRIPTS\YourModelNameWithoutSpaces


      • Did you solved the GPS issue ???

        • Hi

          No GPS issues. Reported Position on the Taranis is absolutely the same on APM Planner/Mission Planner. after converting from degrees, minutes, seconds, thousands of a second to decimal degrees.

          GPS coordinates N and W

          Are you using the Teensy 3.1 ??

  • At the moment LogAnalyzer in Mission Planner is reporting a Vcc problem.....

    Log File C:/Program Files/Mission Planner/logs/2014-10-05 13-01-19.log
    Size (kb) 1994.859375
    No of lines 27919
    Duration 0:15:02
    Vehicletype ArduCopter
    Firmware Version V3.1.5
    Firmware Hash 3c57e771
    Hardware Type APM 2
    Free Mem 1091
    Skipped Lines 0

    Test: Autotune = UNKNOWN - No ATUN log data
    Test: Balance/Twist = GOOD -
    Test: Brownout = GOOD -
    Test: Compass = GOOD - No MAG data, unable to test mag_field interference

    Test: Dupe Log Data = GOOD -
    Test: Empty = GOOD -
    Test: Event/Failsafe = GOOD -
    Test: GPS = GOOD -
    Test: Parameters = GOOD -
    Test: PM = FAIL - 1 slow loop lines found, max 126.77% on line 27919
    Test: Pitch/Roll = GOOD -
    Test: Thrust = GOOD -
    Test: VCC = FAIL - VCC below minimum of 4.6v (4.434v)

    and in a different log.

    Test: VCC = WARN - VCC min/max diff 0.335v, should be <0.3v

    could this be cause by the teensy taking some of the power ?

    I am using the power module that came with my ardupilot 2.6 kit.

  • I thought this was just what I needed!

    I followed the instructions on this post and the description listed on .

    And initially thought great! it works fantastic.

    But after checking the data, the GPS is wrong, at first I assumed I was getting bad data from gps/compass module, however checking the logs from ardupilot, the GPS is spot on in that, but the data I'm getting for taranis is 3-4 degrees out.

    So I took the advice I've read about, updated the firmware etc, re-downloaded the teensy software making sure to check its all the right versions etc. used the latests FrSkySPort 1.3 software.

    Still the same...

    I don't get it, if the data on the ArduPilot is correct, why is teensy/taranis changing something?

    The coordinates I'm getting aren't far out on a global scale, but too far out to be usable..

    Anyone else from the Midlands, England got this working?

    Any more advice on what to try?

    • That's strange. I'm in the N/E quadrant, but the numbers I get is exactly the same in my Taranis as it's reported by Mission Planner (after a manual conversion from degrees in Mission planner to degrees and minutes in Taranis).

      • oh, well maybe thats my problem, maybe I don't understand the format.

        I have tried researching a bit regards different coords but I wasn't able to get anything that matched up.

        Can you tell me how to do the conversion , or point me in the right direction?

        thanks very much.

        • doh, I thought/hoped it would be something very simple like this.

          Just been reading:

          I guess the info was already mentioned somewhere on ardupilot this blog or maybe in the readme files, but me being over eager to to get it runnning

          How to Convert GPS Coordinates?
          Google maps gives the following coordinates: 35.850862 -78.886049 or 35 51' 3.10" -78 53' 9.78"
        • I don't know the correct terminology but basically the coordinates are expressed in degrees. This is what you see in mission planner. The coordinates are expressed as degrees with decimal points.

          You can also use minutes and seconds to express the fraction part of the coordinate. 

          This is when the coordinates are written as 63º 10' 23'' N

          60 minutes equals 1 degree, and 60 seconds equals 1 minute. 

          To convert between mission planer (degrees) and Taranis (degrees and minutes) you take the fraction part of the degrees and multiply it by 60 to get minutes:

          Mission planner: 63,189754

          Taranis: 63º 11.38524'

          Google wants (I think) seconds: 63º 11' 23.1144''

  • It was ok when I used Teensy. But there is something wrong for Arduino Pro Mini. Everything is perfect for Arduino Pro Mini. But, latitude and longitude of GPS is something wrong. It said that "0N00'2.502, 0E00'4.860". Degrees and minutes is zero. When I see the GPS information at MissionPlanner, it is ok.

    I used SoftwareSerial at Arduino Pro Mini for the _FrSkySPort_Serial. Please let me know how to solve it.

This reply was deleted.


DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race
DIY Robocars via Twitter
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0.
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8