APM 2.5 initializing...

In APM Planner (latest version) my apm 2.5/6 wont initialize. When trying to connect it says "initializing", but does not move on.

I just loaded the latest plane firmware onto it.

In Mission Planner (latest version) it does not connect either, it gives me the attached error...

Anybody know how to fix this? I have not used my APM for ages and it was working fine the last time I used it :/

3691223467?profile=original

Cheers,

Sandy

Mission planner apm2.5 error.JPG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • So I did another install of Mission Planner Latest and have since recut the trace to the internal magnetometer - seems I didn't do it properly so many moons ago, I have now been able to upgrade to plane FW 3.3!

    Woohoo! And the compass calibrates properly!

    Winning :) Now time to put it all back into the bixler and get flying!

  • I am able to do the firmware update so I am very confused as to why I cannot connect...

    • Which firmware have you updated to, is it arduplane v3.3

      • Yes V3.3.0

        In Terminal it says

        0 0 0 No compass backends available...

        Do I have an issue with my compass?

        • Admin

          @Sandy,

          I had a similar issue when attempting to load ArduPlane v3.3.0 on an APM2.6.

          After the upload the APM would not respond to MP so I uploaded ArduRover v2.50 which was successful and then reloaded ArduPlane v3.3.0 which successfully communicated with MP however the MP update rate was very jerky.

          So I went to the Config/Tuning screen, selected the Full Parameter List screen, and then did a reset to defaults which cured the jerky update rate problem.

          This process might work for you however you might want to save your present configuration before doing a reset to default parameters.

          Regards,

          TCIII AVD

          • I have other issues now that I can communicate to the board:

            http://diydrones.com/forum/topics/sensors-going-nuts-apm2-5-6

          • Hi Thomas and Martin!

            So I had tried to load Copter and then Plane previously, to trick it into working, but that didnt work so I tried Rover as per your suggestion Thomas, and success! Phew, good to know the hardware is still in good nick.

            I reloaded Plane 3.3.0 and no joy, so I rolled it back to the previous FW V3.2.3 as per Martins suggestion, and success!

            Reloaded V3.3.0 and no joy.

            Back to V3.2.3 and did a "reset to defaults".

            Reboot, reloaded V3.30 and still unable to connect.

            I guess I am stuck with V3.2.3?

            Thanks for your help and suggestions guys.

            • @ Sandy

              Hi Sandy, 

              I tried Thomas's trick and reloaded Plane V3.2.3 then reset all parameters to default, then disconnected, but didn't reboot and reloaded V3.3.0 which worked for me! 

              I'm using my experimental Arduflyer board (with 3.3v diode replaced twice) but I'm going to try my 3DR board later today and will let you know how it goes.

              V3.2.3 is still ok and a worthwhile upgrade.

              BTW  if it's any consolation I think that we're pretty near to the end of useful life of the APM 2.5, lot's of the new features that are coming in only working on the PX4/Pixhawk now.

              I'm still going to persist with my APM 2.5's though, using them as back up or for experiment   

              @ Thomas thanks it worked!

              • Sigh, nope, that didn't work for me. Back to 3.2.3 for me...

              • Great - I'll give it a try.

                Yeah its a bummer but hopefully the APM will retain some use with the tracker project. When the new FC comes out (Pixhawk 2?) I'll probably get one for my quad, and bump the Pixhawk to the plane... but until then, I'll keep flying with the APM in the Plane!

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…