APM 2.5 Super simple mode on ch7 or ch8

Hi,I set the super simple mode to ch7 / ch8 at the Mission Planner APM:Copter Pids.When I was flying to test it, nothing happend. It seems super simple mode doesn't work if set on ch7 opt or ch8 opt.In the instructions under "simple and super simple mode" it said this option is available for a 2 position switch but for a 3 position switch it is not available before version 3.1I use a 2 position switch so it should work.Has anyone tried this ?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I found a half solution !!

    Super Simple mode is enabled by setting the parameter named SUPER_SIMPLE to 1 (0 disabled default) in the Parameter List in the Mission Planner’s Configuration section.

    If you've done this and set "simple mode" to ch7 or ch8 opt it will fly in "super simple mode".

    If you want to fly in "simple mode" you need to set the SUPER_SIMPLE parameter to 0 and set the ch7 or ch8 opt to "simple mode".

    I know it's not logical but it works at least on my quadcopter. 

    I'm sure this is a bug at the APM or Mission Planner !

    I haven't tried simple or super simple (permanent) on one of the 6 flight modes yet.


  • I have Simple Mode w/ Super Simple Mode on one of my six flight mode selections.

    I only tried it a few times, but found it did nothing. (ie, acted just like Stabilize)

    In an earlier configuration, I did use Simple Mode (w/out super simple mode) with success.

    If I had to guess, I'd suspect that Super Simple Mode is not working?

    (My Chan 7 switch is RTL, which works just fine.  I haven't tried using Ch7 for anything else.)

  • I just posted a note in the  3.0.1 thread about this in case there's more people there that have run across it.

  • After multiple "try & error" tests with CH7 & CH8 options, still cannot figure out WHAT's Wrong with the Setting.
    Finally, I found this similar topic here : " ch7 / ch8 NOT WORKING at the Mission Planner APM: [Copter Pids]" !!

    Hi, there.
    It is SAME here with APM 2.6 where NOTHING HAPPEN even ensured reading >1800PWM neither CH7 nor CH8 for all the OPTIONS in the list.

    Note: Except "Trigger Camera" option in CH7 is WORKING with enabled Shutter Setting under [Initial Setup]

    Hoping Ardupilot Experts able to advise here !! 

    Good Day ! 

  • In fact I cannot seem to get the Simple or Super Simple modes to work at all even if I put it as one of the standard 6 modes.  Anyone else?

  • Ditto - I have ch7 set to super simple mode.  Flipping the switch (Which I have confirmed multiple times is sending >1800PWM) is basically having no effect.  Seems like a bug unless we're all misunderstanding how this should work.

  • Me to, simple and super simple do not work unless the copter is in a failsafe rtl, or geofence rtl???

  • I've tried simple mode (not super) on ch7 on a 2 position switch and checked radio calibration but when I fly it did not work.

    Dit you try simple mode (not super)?

This reply was deleted.