APM 2.5 Twitching problem


I have some serious problems with my 3DR Quadcopter with APM 2.5 and 3.0.1 firmware.

When I fly, the Quadcopter is twitching about ones every couple minutes in one direction. Forward, backwards, left right and even upwards. Also sometimes the signal loss fail safe kicks in even I'm only about 15 meters away. 

I did a range check and it is fine, no problems. 

What I did so far trying to solve it... without effect:

- Checked all motors if they're faulty.

- Used other ESC's.

- Tried different 5V power sources like ESC's BEC, 3DR Power Module, stand alone UBEC.

- Eliminated vibrations and electromagnetic interference as much as possible.

- re positioning the RX antennas. 

- Checked logs and found there are spikes at the Roll In, Pitch In and Thr In at the time the Quadcopter was twitching. ( see attached log file and picture )

I'm grateful for any help since I tried to find the problem for a long time now and don't know what to do anymore.

2013-09-02 20-11 8.log


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I can use my DX7s again.

    I found a thread that shows another method for setting up 6 flight modes on the Spectrum DX7s using 1 channel . This took care of the twitching problem related to ch6.


  • Good find Steffen. I ran auto tune multiple times on my APM quad. The twitch was always still there. I was using my Spektrum DX7s radio that is set up for 6 flight modes. It accomplished the 6 flight modes by mixing channels 5 and 6. I switched radio and receiver to my Turnigy 9x (it doesn't use channel 6 for the 6 flight mode setup). That took care of the twitch. Imagine that, using a cheaper radio for better flight.



  • Problem found !!

    The twitches occur only if the input of the APM's ch6 gets high input (100%). Like when a switch on the Tx is in position 1 or a nob is turned up.

    When I reduce the input of ch6 to about 50% or disconnect the wire to ch6 input entirely, the quadcopter stops twitching and flies perfectly.

    To be clear, ch6 on the APM's input is not enabled to any ch6 options or gimbal use at the Mission Planner. Only connected by wire to the Rx to use a switch or nob on my Tx.

    I'm therefore not able to use any ch6 opt at Mission Planner like "Rate Roll and Pitch Tuning".

    Does anyone has this problem too or found a solution ?

    • Did you find any solution regarding channel 6?

      I may be having the same symptoms.
      • This is what I found out was making the twitch.  I was having the same issue and figured out that what was happening is that I was inadvertently putting my quad into autotrim mode and since I was flying around or hovering with no regard for the autotrim function, it was getting totally confused. That is the only time I would get the twitching. Like it would twitch when the autotrim sequence was finished after a minute or so and since I never land and turn off the throttle the trim is never saved. So the next time if I got the arming right and not in autotrim, normal flight and no twitching.

  • My TX/RX is only a simple Devo 10. Therefore I don't use PPM.
    I used it on a different quadcopter and it worked fine.
    I'll try to reset the APM and will see if this works and post the outcome soon.

    Thanks for your help so far.
  • Developer
    For Futaba, You don't have to update the PPM just put it in, 7channel mode. The newer PPM syncs better when using the extended channel mode.
  • If you are running Futaba and have not updated the ArduPPM encoder to the latest version this could be the cause of the problem.

    I believe it also occurs with some other Rx's, so have a read up on the wiki about ArduPPM and when you should upgrade.

  • T3
    Have to tried to erase, reset your APM. Then reload firmware and reload your parameters. Make sure you save your parameters before you start. You can also use compare when reloading your parameters.
This reply was deleted.


Santiago Perez liked Santiago Perez's profile