APM 2.6 enters failsafe_battery and Lands after few minutes

  My APM 2.6 enters failsafe_battery and Lands after few minutes. I am almost near to my dream to make an Aerial rig and this is stopping me. I am attaching my last Data Log. Any support is appreciated.

this is my Quadcopter Specifications

Frame :

 Q450 V3 Glass Fiber Quadcopter Frame 450mm - Integrated PCB Version

Motors :

Multistar 2212 - 920KV Multi-Rotor Motor Set w/CW and CCW Threaded ...

ESCs :

EMAX Simon Series 30A ESC

Propellers

 : 1045 propellers

Radio :

Futaba 10J FHSS 2.4GHZ RADIO WITH 2800MAH LITHIUM BATTERY AND CHARG...

Battery :

Tattu 2700Mah 3S1P Lipo Pack

Gimbal :

3-Axis Brushless Gimbal Camera Mount with 32bit Storm32 Controller ...

Misc Parts:

Xiaomi Yi

 

Li-Po Battery Voltage Tester & Buzzer Alarm 1~8 Cell

Landing Gear Set for F450 / S500 / F550 Quad

All Up Weight:

~1.25Kg (With out battery)

Views: 177

Attachments:

Reply to This

Replies to This Discussion

I don't see voltage drop to 9.75v (your fs_voltage) - but the logging is slow, and maybe it's there, the battery does not handle very well the load, too puny battery/too high current/too high internal resistance.

Thanks Andre K,

Even the motors are getting hot with Tattu 2700Mah 3S1P 25C Lipo Pack and my earlier flight with Turnigy 5000mAh 3S 25C Lipo Pack is too bad it just lifts a foot height and land.

So should I change my Battery with a higher C rating one, or change my motors?

My quad's All Up Weight is ~1.25Kg (without battery)

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service