APM 2 GPS not getting a lock?

I have been sitting here trying to get a lock with my GPS while outside for about 10 mins.  No luck.  I generally get a lock between 30-60s when outside.  My GPS has worked fine previously.

Other than the CLI test (which only works if I have lock anyway), is there a way to check GPS function?

If my GPS unit turns out to be no longer functioning, what options do I have with the APM2?  Since my GPS is soldered directly to the board, is it possible to get another and use an extension?  I don't trust my soldering abilities enough to remove and replace the current unit


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I also was not able to get a GPS lock unless it was plugged into the UBS. I had my gps line ziptied next to my servo wires. I cut the ziptie and gave the gps line a little room and it solved my issue.

  • Thanks Chris, I wasn't emailing them to harass, I just wanted to firstly confirm that they received it and see how they were going. Thanks heaps for your help.

    You seem to be the go to man when we need a response. Much appreciated.

  • Quick question,

    I have sent my APM2 back, but havent heard from anyone. Its been probably a week and a bit since they should have received it. I emailed them to confirm it arrived, no response, emailed again 3 days later for an update, no response.

    Is there a particular email address i should be using? just been emailing help@3drobotics.com

  • I have a similar problem.

    From New my APM2 got gps lock maybe 4 times. Took 10+ minutes each time to do this.

    Now... I dont get a lock at all.

    I have not been able to use the APM2 successfully since new. I emailed tech support, but got no reply.

    Whats the general course of action here?

    I'm not going to justify buying a new gps module for it because the original has never worked properly!

    Should be a warranty job as far as im concerned.

  • What does the CLI tell you if you don't have a lock? One way of Disabling it is using a 4k resistor and soldering one end to pin 2 of the GPS and the other end to either pin 3 or ground. Then using a ublox. 

    Also it seems that 99% of them work fine, it's just that no one ever makes a post about how many problems there NOT having.......But as soon as they have a problem you here about it. There is acutally a troubleshooting forum just for this stuff, (I didn't see until I had already made my post). You will probably have better luck there so the people that can help you see your post. Rather then just seeing it somewhere else

    I will however let you guys know how mine turned out and what I learned from the experience that might help you.

  • Finally my problem was with the fpv camera, I disconnect it and the gps lock, I connect and lose sats, so I

    move que camera and the cable far from the gps and solve the problem; Thanks.

  • I get gps read timeout........ How can I sure it's even talking about the ublox though? The onboard has been disabled (pin 2 set low)

  • 2.6........ I let the mission planner download the latest firmware

  • Well it came from them 2nd day air yesterday so Im guessing it's the new model......

  • HI all,

    So George....your system works as per standard!....this is good....and you can have a 900meg close to the GPS wil no obvious ill effects...

    perhaps its something wrong with my personal one?! (I have been trying to buy a 413meg 3dr pretty much since there were released, but seems to be almost alwaysout of stock :(   )

    Jake, thanks for the heads up, as to me radio is like a 'white mans magic' i dont understand it, conceptually yes, how it actually works in reality, never got down and dirty with it. more over, i use off the shelf gear, adn the other data rx/tx systems i have are mil-spec for other projects, so not a fair test, (also most of them, will knock out GSM fro about 5 miles once airbourn, which tends to upset the neighbours! So i dont use it out of cleared areas.

    My 900 is an old Xbee (probably as old as the MK1 DIYd AP) and had a few muddy/wet moments in its life.

    Thanks Will, i will disable the others i have on APM2's instead of ripping them off the board.(y anever know we might get to the bottom of this issue and be able to use them again.

    In answer to steven's question, teh mission planner renderes the number differently, HDOP on u-centre will read 1.2 or 3.5 etc, planner read 120 or 350, MTK also works the same way in its set up software you will get 1.2, the moved the decimal place. Best to see the GPS in question direclty on its testing program, thebn correlate the numbers back to the planner, if that helps.

    If anyone has an old Xbee and cares to try this, i would be very gratefull for your results.

    Kind reagrds,


This reply was deleted.