APM 2 locking up.

Hey everyone,

 I just got my APM 2 today and was excited to try it out especially because i crashed and destroyed my APM 1 a few weeks back. it looked to power up great out of the box but i cant seem to get connected. after uploaded firmware and checked the terminal to see what was up and everything was going great unitl i tried to test imu. thats where it got stuck. i shrugged it off and tried to connect using HK GCS but after connecting and hitting the reset switch it would lock up at random different parts of start up. in the arduino serial monitor it locks up at "init gyro" same goes with APM Terminal. Do i have a bad board, or am i missing something?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So... very unpleasant day to the field today... we've encountered some of the problems we had before... even bricked the XBees once (this haven't been happening in a while, still painful having to unmount everything to unbrick them)...

    BUT... we managed to get it working powering first the board with USB. If we boot from battery APM2 locks half the time or less... we then get this weird GPS problem i've explained before : sats counting, sometimes up to 8, never finding a fix, then dropping back to 2 or 3 and counting again... never finding the fix.

    We plug the board back on USB : instant fix. Then battery boot, no fix...

    Again we've tried erasing, resetting, uploading with mission planner, arduino, even compiling from GIT with arduino... It NEVER works.

    With THIS procedure, it has worked 4 times on the last 4 tries (we were running out of batteries) :

    — Plug the board to USB and wait it to boot (Xbees unplugged)

    — Connect to mission planner, it resets the APM2 and it boots again (let it calibrate well until it shows ready to fly)

    — Connect the battery (maybe the board will reboot again, if it does let it go through the procedure once again)

    — Disconnect mission planner and unplug USB

    — Connect the GCS Xbee on the computer (if the plane's Xbee is already connected don't, it will either mess up windows with the serial ballpoint mouse bug, or brick the Xbee)

    — Connect the plane's Xbee

    — Connect the mission planner (with Xbees)

    Then again this procedure is VERY painful, but for us it appears it's the only way to go... The GPS was first incriminated but using this procedure shows no problem at all. It must be Arduplane related...

    I've found a reference there : http://code.google.com/p/ardupilot-mega/wiki/Troubleshooting

    (I'm using a MediaTek GPS, and although the module's blue lock LED goes solid, APM is not showing a lock)

    However it seems to be related to APM1... but still, same problem with APM2...

  • 3D Robotics

    Hi Emiliano, we have seen this problem in the past. The cause is the dataflash card not initializing correctly. To verify this is the problem, take it out and try to power your apm 2 again. You should be able to go through the tests in the CLI successfully. If this was indeed the case, there is an easy fix. Put the dataflash back in, and power the board up while looking at the terminal screen. It will reformat the card (this will take A WHILE). Leave it plugged in for a good 5-10 min. After that you should see a "ready to fly" message. You only have to do this once. Hope this helps

  • I fixed my tri-copter...  before the crash, it would not boot also... Solid blue light sometime...

    now the ecu's dont arm on power up..   I unpluged the tail servo, and it boots and arms ecu's every time...

    Plug the tail servo back in.. does not boot and or will not arm ecu's...  Strange.. Jumper is off.

    My tail servo gets its power directly from the receiver but the signal from the APM2...

  • Sorry for spamming this forum but I wish update you with some other tests.

    I've loaded the firmware 2.28 with Arduino (not using MP) and the board start and work fine.

    I've done 20 reboots, no problem at all.

    So, I've reloaded the 2.28 with MP, the board won't start, locked at INIT GYRO.

    Again I've reloaded the 2.28 with Arduino and APM2 work fine.

    maybe MP planner is doing anything wrong? (EPROM values, or else....)


    Any idea?

  • Hi,


    after some test I've discovered to have the same issue.


    The board stop loading on INIT GYRO, after that the board stop respond.

    The only way to boot is to press reset switch.

    Bad board?

  • We experienced the same yesterday... problem is... the plane was airborne ! Hopefully we were testing loiters just above us when all of a sudden we lost telemetry, RC... everything. Plane loitered down, almost hit my car, and landed quite alright in a field nearby... Lucky it was the test plane, if it occurs again someday on a mission with the real plane loaded of gear it could be quite catastrophic...

    Using MP 1.1.40 and ArduPlane 2.28 uploaded through MP.

  • Mine has done this twice now. The first time I don't know what I did to fix it. Removed all cables from it and let it sit for a few minutes (this was after power cycling it to attempt to diagnose the problem), and then it just worked. It just froze on me again a week later, after everything was working fine. It has yet to come back to life...

  • I too have verry rarely that sometimes it won;t boot up the first time. But after taking power of and back on it will boot again. My guess sometimes there is a glitch during boot.

  • i have the same issue. i ordered 2 boards. one is working fine, since i installed mp 1.1.16, the other has the same problem.

    i use a 64bit win7 computer.

    i really hope it´s not a bad board...


  • Developer

    How are you uploading the code?  straight from the AP Mission Planner or are you downloading the code from git and then uploading with the arduino ide?

This reply was deleted.