Developer

APM Copter 2.9.1.b has been released

3691010694?profile=original

APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Randovan, I'm curious as to what settings you have ended up changing in the gps. I tested and played with many many different configurations and ultimately ended up back with the stock setup and only one or two alterations. My experience was that when a setting didn't get saved it was that I forgot to commit the change to the eeprom.
  • Hey guys,

    Can anyone help me read on my log whether my vibration dampening is good?

    It has now 3 layers(previous 2) of dampening but still my loiter is bouncing around in the wind. Stab is all fine.

    Can't be sure which is the right file i should upload because it's name based on download time rather than flight time so here's 3 log file with the biggest file size.

    Thank you

    2013-05-18 17-15 2.log

    2013-05-18 17-14 1.log

    2013-05-18 17-16 3.log

  • Developer

    I've just put AC3.0-rc3 into the new downloads area here and in GitHub and the MissionPlanner should start dispensing it shortly through the Beta firmwares link.


    Improvements over 3.0.0-rc2
    1) bug fix for dataflash erasing unnecessarily
    2) smoother transition to waypoints, loiter:
        intermediate point's speed initialised from copter's current speed
    3) Ch8 auxiliary function switch (same features as Ch7)
    4) safety checks:
        Warning to GCS of reason for pre-arm check failure
        ARMING_CHECK parameter added to allow disabling pre-arm checks
        Added compass health and offset check to pre-arm check
        compassmot procedure displays interference as percentage of total mag field
    5) WPNAV dataflash message combined into NTUN message
    6) allow TriCopters to use ESC calibration

    All feedback welcome.  I think we're getting close to a final release.

  • My last compile I noticed the options changed in the config... is 'quad' = 'quad X'? Not that I would ever use it, but is 'quad +' gone now?

  • Has anyone else noticed that Mission Planner 1.2.51 has a serious bug displaying barometer readings, the readings quickly rise to +30m and down to -30m in less than a minute with the board sitting on the bench. uninstalled 1.2.51 and installed 1.2.50 barometer rock steady as it should be.

     

    I wasted a lot of time trying to figure out why my barometer died, when in fact nothing wrong with my barometer Mission Planner 1.2.51 is flawed.

  • help running 2.9.1 b on y6 with recommended props, stabilize feels ok but when i switch on altitude she bounces up and down, probably an inch or two oscillation, what can I do to eliminate that? thanks in advance.

    2013-05-20 23-23-26.rlog

    2013-05-20 23-23-26.tlog

    https://storage.ning.com/topology/rest/1.0/file/get/3692721531?profile=original
  • Tried mission with 6 waypoints.

    Defined Auto as my sixth flightmode.

    After takeoff i switched to Althold and than Loiter before i switched to Auto. The machine went very fast the right direction and the speed rised. I wenbt back to Loiter but than the machine was impossible to fly in the beginning. After a while i got control when it went more calm. I had a loooong ride with problems with my orientation, about 1,5 km away but managed to get it back (simple mode).

    After landing i was very suprised since no logs in APM, got erased when entering CLI, see here:

    3692720900?profile=original

    Have i missed something?

    Here are my planed and saved/uploaded mission:

    3692720796?profile=original

    Here are the waypoints from APM when connecting via USB. One waypoint (3) is far out. Actually the machine was flying this direction but i aborted and than started to get orientation problems and ended 5 times longer "out". How did this happend to waypoint 3?

    3692720972?profile=original

    Need some help on this...

  • Thanks Team!!! 3.0 loiter tracks very straight and smooth with ONLY forward elevator and a very strong crosswind :D

  • A bit of testing today. 

    I generally test each item, one at a time, and don't progress until I'm happy.

    So I've been stuck on alt hold since 2.91b came out. It's been back to terrible with massive jumps and drops again. Finally I ripped out my 1260 sonar (again), and the quad does alt-hold like a dream. I guess I have to buy yet another sonar (my third) for it to work (1340). 

    So I moved on to loiter. And it seems perfect. I did have 12 satellites locked in for awhile, and there was no perceptible movement at all. It's still a little twitchy (but holding in place), and I'll need a gimbal if I ever get serious with video. 

    No auto flights yet on this firmware. RTL test will be next, then after that full auto course with some ROI.

    (One thing at a time). 

    I'm getting very confident with my flying, took it up to 160 feet, no fear. :-)

  • Problems with v3.0 rc2.
    APM 2.5 w/ublox on S800 standard configuration 2 x 6S 8000mAh

    Drifting to right all the time and ended with a minor crash, suddenly impossible to control before crashing.

    Logs attached from 2 flights.

    Can't find current voltage data in logs, all tough I have "current" enabled.

    logs.rar

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…