Arducopter 2.0.38 quad always wants to flip

Damn thing thinks its a 15 year old gymnast. I'm really frustrated and sick of going through 10x4.7 props so I switched to 9x5x3 and lost the landing gear for weight savings. Disconnected every motor last night and reconnected, ran motors command in CLI, reverse props are on clockwise motors. Recalibrated the throttle on the ESCs. Ran the motors at full throttle for a while to verify no bad motors or ESCs. Frame is set to X.

Note the throttle increase just as its about to lift off? Thats not my input. I'm throttling DOWN every time it gets close to flipping if anything...

I've seen previous threads about this problem and it was always prop related. But I've verified my props 5+ times and gone through too many 10x4.7s trying to diagnose this.

I'm happy to post anything necessary to figure this out. Thanks for the help. I am using APM Planner 10.0.52

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you ever solved this issue??  I love the vids, your dog reminds me of mine.  Since your quad hovered for a bit, all motors and props are connected.


    Did you ever figured the problem?

  • Radio
    CH1: 1116 | 1917
    CH2: 1119 | 1919
    CH3: 997 | 2038
    CH4: 996 | 2035
    CH5: 1115 | 1920
    CH6: 1113 | 1913
    CH7: 1499 | 1499

    Quad frame
    X mode




    Mag Dec: 12.3965
    Mag offsets: -50.3366, -8.3673, -24.3040

    Motors command just displayed some very interesting behavior. The first time I ran it, I would hit roll left and both left motors would turn on, pitch forward, forward motors run, roll right, right motors run, pitch back, back motors ran.

    Then the second time I ran motors after redoing my radio in CLI again and the motors ran completely different. This time each corner I would push the stick, the motor would run in that corner rather than the behavior before of both motors running. Another time I would push the gimbal back right the right motor would go and the left motor would startup after 3-10 seconds at varying timing. I took video of all this if it doesn't make sense. Let me know if you guys would like it uploaded.


  • could be several things:

    1) your accelerometer offsets were not set (in CLI or Mission Planner)

    2) your motors/props are spinning in the correct direction, but ESCs are connected to the APM in the wrong order. 

    3) your APM is mounted in X mode but firmware is in + mode (or vice versa)


    I'm inclined to think it is #2 or #3

    if #2 turns out to be the case, be sure to check to make sure you have the correct prop and motor orientation again as it may be changed!

  • Moderator

    Can you post a pic real quick of your quad? I know you've gone over the props, but, you know...  ;)

  • Hi. Have you checked that you don't have any prop upside down ? Each prop has a up side and a down side, usually the up side is where the letters with the reference of the prop are. To have a ccw and a cw, it's not a matter of flipping one prop, they are specific for cw and ccw, the profile is not symetric, if looked from a side, the blade looks like a plane wing. Another thing, check that you don't have an ESC with brake on configuration. Check your ESC manual about "brake" function. If one or two have the "brake on" and the others have "brake off", the propellers will react different, and it could be the cause. Hope to have helped.

This reply was deleted.