Arducopter 2.0.48/49

There is a preview on GIT right now. I flew a version of this


The PWM output has been set to 400hz (to counter the low pass filter in most Turnigy PWMs)

The DCM's Roll and Pitch gains were lowered to .03 (recommendation of Hein Hollander)

Mavlink has gotten a re-work for performance and memory savings.


Added a scaling factor to camera Roll And Pitch CAM_P_G, CAM_R_G in the params list.

Fixed some bad PID values for Alt hold that were giving folks trouble.

Exiting a WP for another is faster and more controlled now.

Added user hooks for those who want to execute their own code inline.

Increased loiter speed to center when the copter is flown > 400cm (now 800cm).


Loiter in action.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hi

    i use 2.0.49 firmwar, all work fine but my GPS give me error coordinate, my location is lat46.802997, long-71.176128 and the gps (MediaTek MT3329 GPS 10Hz)  give me that lat 46.802997,long 146.187650, always error on long  ( signal 6 Sat and GPS Lock solid), what can i do befor changing GPS ?


  • Jason et al. a possible bug in the calc_loiter function:


    float temp = radians((float)g_gps->ground_course/100.0);


    If you get the ground course of the GPS while in loiter you will probably get wrong results, ground course in GPS is reliable only when travelling at speed > 5 km/h. How can you get it while Loitering?

    You then use this to calculate rate error:


    x_actual_speed = (float)g_gps->ground_speed * sin(temp);


    and calculate PI on it.

    y_rate_error = y_target_speed - y_actual_speed; 

    nav_lat = g.pi_nav_lat.get_pi(y_rate_error, dTnav);


    This probably explains why the copter flies around. When it reaches a decent speed, it gets the correct bearing and then  heads to the correct location, resulting in a sort of circle.

    Please correct me if I'm wrong.



  • i have open a topi with a problem , but i think that i found a bug at the planner in combination with .49

  • Had a good couple of flights with 2.0.49 today. Just tested Stabilise, Alt Hold and Loiter. Great results

    Loiter was a tiny bit disappointing - in that in Alt Hold with only a slight breeze the aircraft would stay fairly steady in the one place. When I switch to Loiter the aircraft starts to fly around a 3-4 metre radius circle after a few seconds. Nudging the controls stops the circle for a short time then it starts circling again. It's the comparison between Alt Hold (steady in the one spot with little or no input) and Loiter (3-4metre circles) that is disappointing. All standard PI values no tuning.

    Attached is the log and relevant graph from the Mission Planner


    249 test
  • I switched from 2.0.45 to 2.0.49 today and managed to get two flights in towards the end of the day in calm conditions.  I tried ALT Hold on both flights and the quad is jumping i.e motors are pulsing again.  It is quite pronounced now on 2.0.49 than it was when I tried the same hardware setup on 2.0.45 i.e it was very intermittent.   Now if I had not spent the last three weeks focusing on the sonar I would be looking at the usual suspects but now I see the familiar  throttle oscillation but more intense.  My Sonar is mounted well clear of the electronics( ~ 4"), has a power filter and good shielded cabling.  The worst part of the ALT Hold behavior is the unexpected climbing.  I was very lucky to catch the quad because before I could blink it was (according to the flight log) some 133ft from the ground. I tried engaging ALT hold a few times and it just keeps trying to climb.  I thought it might stop once the baro kicks in but this is how I manged to almost loose my quad when is climbed at the highest rate.


    I tried Loiter mode next and the quad is not able to stay on point.  The GPS is locked solid the  whole flight so I am not sure why the quad seems to eventually fly away from me requiring manual intervention to bring it back.  Pehaps to standard Loiter radius is very large in the default code settings,  Do we have to change a value to make sure Loiter keeps the quad in a tight radius?


    I really am so close to giving up on this project as I cannot seem to get anywhere near what other people are reporting, especially on 2.0.49.   So far I have changed 6 motors to get a really low vibration free frame, replaced 2 sets for prop spinners again for balance reasons. On the electronics side I have replaced one ESC and the IMU Shield and the APM. All to remove possible sources of interference or faults.


    Is there a way I can temporarily go back to the 2.0.45 code using the mission planner or will it only load the current linked code? I want to try the exact setup to see if I have the same issues due to some new electronic problem rather than the software.


    My arducopter is a standard build (complete kit) except I am using the store offered 880KV motors with 12 x 4.5 props.The only parameters I changed on 2.0.49 is reducing the Stab Roll and Pitch P to 3.2 and increasing I to 0.01 respectively. One last check is the Maxbotics XL-Sonar EZ0 (MB1200) the correct sonar?

  • FInally got good enough weather to test 2.0.49 on my standard frame. Loiter is working really well after I tuned my Nav_loiter_P to 0.279. Oscillation is gone and it hovered very nicely in a 3 meter circle. It was the first time I felt safe doing a loiter in close quarters. I flew 6 packs checking things out and I did a 6 minute loiter at 15 meters in a small wind with excellent results. Baro hold is up or down 4 or 5 meters, but loiter was very good and I was more relaxed on the sticks then ever.  Awesome. 

  • Tested 2.049 indoor today, made some PID tweaks, now copter is very stable, no oscillations at all. It must be the best firmware of all.

    Here is a short video:


  • Hey guys, everything is working great, loiter including except my Y6 is yawing very slowly still. Having set a yaw trim only helps slow the eventual yaw down unlike what I thought it was doing earlier. Any idea on how to fix this? My motors are perfectly straight, I wasnt getting yaw on .46 but loiter+althold wasnt working as good as it is now.

  • Just a question to all of you: I was using 2.0.46 before and then switched to 2.0.49, nothing else changed. In 46 I was able to see logs in the MissionPlanner log window, but with 49 it never shows any logs available. If I do 'dump 0', it will print a bunch of data that I can copy over to a textfile and display, but never does it show actual log files to download in the menu.

    I'm not even sure it has to do with the swap to 49, I'm just trying to figure out what to do about it. Thanks!

  • Today I make a flight with .49 and tuned the baro.

    Now my copter flight very stable in Loiter.

    Here are the logs:

    The only things I have changed are the Loiter P to: 0.3 and the Throttle P to:0.36


    On the pictures it´s only loiter modes. I have deselect the stabalized modes.


    3692290083?profile=originalAnd here a picture for the hight:


    I will now go on with automode

    2011-10-22 04-48 3.kmz

    2011-10-22 04-48 3.log

This reply was deleted.