Developer

ArduCopter 2.7.1 Released

ArduCopter 2.7.1 will become available on Mission Planner and in the downloads area shortly. This release contains a few important bug fixes as well as the first implementation of the MPU6000 sensor-fusion code. 

Detailed changes are in the commit log. Here's a summary:

New:

- Preliminary support for MPU6000 on board sensor-fusion (DMP)

- AP_Limits: Experimental "bounce" mode, for smaller spaces (LIM_RECMODE)

Bugs:

- Bug fix for yaw error buildup on takeoff

- Fix in Auto mode for failsafe handling

- Fixes to 3-axis camera gimbal code

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Can the sonar not be used to calculate the rate of descend?  This calculation can then be used to calculate how long it would take to reach the ground and then once the ground is reached it can immediately reduce the throttle to zero...

  • Wooa.  The 2.7.2b Camera Mount configuration has changed drastically.  Parameters have been renamed and new fucntions added to mission planner.    Can I get some hints on how to make it work?  My camera mount used to work great in 2.5, not so great in 2.7.1 and now nothing in 2.7.2b.

     

    The capability is really going in a great direction - I see a lot of work happening in the area of configurability - With no wiki updates yet, some hints for how to set it up would be greatly appreciated.

    I'm using APM1. 

  • Hi

    My T-Rex 450 flies nice in Stabilize, and Alt Hold works very well with Barometer  +- 1m in windy conditions. :-)

     

    But I still have a problem with the Compass.

    If I connect the APM2,5 ArduCopter 2.7.1   via USB to the Mission Planer and check the Compass readings at the  “Mission Planer Terminal   Test   Compass”,  the readings are absolute correct and no drift, but everywhere else in the Flight Data the readings are very much off , up to 50 deg. and drifting.

    What process lies between the data from the “Terminal   Test   Compass” and the Flight Data?

    If the readings from the Terminal would show up in the Flight Data readings, everything would be ok.

     

    Does everyone else suffer this symptom??  

  • hi all:
    Some information on improvements to the v2.7.2
    http://code.google.com/p/arducopter/downloads/detail?name=ArduCopte...

    and upload it to the quad and this weekend to fly

  • I'm a reporter for Metro International newspapers (www.readmetro.com), and am working on a story about DIY drones. Sorry to jump into your technical discussions! I'm interested in speaking with drone enthusiasts about why this is such a compelling activity, what your drones do and what their potential is. Please feel free to contact me at elisabeth.braw@metro.lu.

    Many thanks,

    Elisabeth

  •   I cant find an updated wiki for the new APM2.5 board. Is there one?

  • Stab fine! Turn to Alt_Hold wait 3~5 secs and the quad descends.

    Tried it and the same happened four times in sucession.
    This is with v2.71
    This is the first time I've experienced this! Only difference this time from any other is that I'm using the apm v5 board.

    Any ideas?

    cli still says dataFlash not inserted so no help from there yet...

    Peter

  • Hi,

    I fly my hexa with Naza GPS.

    How can I use AMP2 only for data logging? Any chance of get a program?

    Thanks,

    Pablo

  • No dataFlash inserted (new problem)

    Have upgraded one of my quads with the version 2.5 pcb. As you know this has the on-board chip dataFlash, I had hoped that the erase, and associated problems would have been a thing of the past!

    Well initially, Loaded it with v2.6 in order to test motors etc for surging. The dataFlash functioned fine.

    Erased dataFlash. Complete fresh install of v2.71 FW. erase and reset eeprom. complete re-config. First off cli reports no dataFlash inserted!

    Have done about 5 flights today, cli still says dataFlash not inserted. Now we know that is now not possible!

    Is this a Firmware or a mission planner problem?


    Peter

  • Hi, i fly with a hexa and apm1 fw 2.7.1 Stabilized fly is great but when i switch to loiter mode i get many wobble with and without wind. I try to decrease Rate Loiter P and Speed Loiter P but wobble are always.

    Any suggestions? how can i do?

    thanks

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…